summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-28 10:47:37 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-28 10:50:00 +0100
commitf6b95b424eed211f3b32dee5e913cceb4915d282 (patch)
tree9e7cd7c89bb68bac24d88a4ee59903b93e233ba0 /x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild
parentwww-client/epiphany: remove old (diff)
downloadgentoo-f6b95b424eed211f3b32dee5e913cceb4915d282.tar.gz
gentoo-f6b95b424eed211f3b32dee5e913cceb4915d282.tar.bz2
gentoo-f6b95b424eed211f3b32dee5e913cceb4915d282.zip
x11-libs/c++-gtk-utils: Versions 2.0.34 2.2.19
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild')
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild
new file mode 100644
index 000000000000..d025f98f1065
--- /dev/null
+++ b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.19.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
+HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk nls static-libs"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.26
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk) \
+ $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --without-guile
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}