summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-05 22:20:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-06 00:27:45 -0400
commit8b1535336edc4a2aee3574611f665716588e6b31 (patch)
tree37b3b114bb102a1831fb91a64cd00fd225f55254 /x11-drivers
parentgui-libs/egl-wayland: stabilize 1.1.12_p20230718 for amd64 (diff)
downloadgentoo-8b1535336edc4a2aee3574611f665716588e6b31.tar.gz
gentoo-8b1535336edc4a2aee3574611f665716588e6b31.tar.bz2
gentoo-8b1535336edc4a2aee3574611f665716588e6b31.zip
x11-drivers/nvidia-drivers: adjust IBT warning again
Hoping to be able to remove this from 535 branch at least, but I have no way to really confirm so leaving it there for now. Last time I removed this warning I just got someone on IRC with issues who wondered why the ebuild didn't warn about this but that was with an older version. This aside, do disable warning with USE=kernel-open, pretty sure that should always be fine. Having a bug open to track this should be useful anyhow. Bug: https://bugs.gentoo.org/911142 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild8
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild10
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.47.35.ebuild10
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-535.86.05.ebuild10
5 files changed, 28 insertions, 17 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
index ef9ad02b96d9..41901b039ab5 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
@@ -93,14 +93,17 @@ pkg_setup() {
~!LOCKDEP
~!X86_KERNEL_IBT
!DEBUG_MUTEXES"
+
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and optional nvidia-drm.modeset=1.
With 390.xx drivers, also used by a GLX workaround needed for OpenGL.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, *if* modules fail to load with ENDBR
+ errors, then try to either unset or pass ibt=off to the kernel
+ (default if no CPU support). Ignore this otherwise." # bug 911142
kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
index 9236174320c5..176d15df8cfa 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
@@ -95,14 +95,16 @@ pkg_setup() {
~!SLUB_DEBUG_ON
~!X86_KERNEL_IBT
!DEBUG_MUTEXES"
+
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
- to be fixed but, *if* modules fail to load, then try to either unset
- or pass ibt=off to the kernel (ignore this message otherwise)"
+
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, should be fine but *if* modules
+ fail to load with ENDBR errors, then try to either unset or pass ibt=off
+ to the kernel (default if no CPU support). Ignore this otherwise." # bug 911142
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
index 270d42f08bfc..b11185284175 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
@@ -97,16 +97,18 @@ pkg_setup() {
~SYSVIPC
~!LOCKDEP
~!SLUB_DEBUG_ON
- ~!X86_KERNEL_IBT
!DEBUG_MUTEXES"
+
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
- to be fixed but, *if* modules fail to load, then try to either unset
- or pass ibt=off to the kernel (ignore this message otherwise)"
+
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, should be fine but *if* modules
+ fail to load with ENDBR errors, then try to either unset or pass ibt=off
+ to the kernel (default if no CPU support). Ignore this otherwise." # bug 911142
+ use kernel-open || CONFIG_CHECK+=" ~!X86_KERNEL_IBT"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.35.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.35.ebuild
index 76ec64976572..8421427a0a25 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.35.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.35.ebuild
@@ -98,16 +98,18 @@ pkg_setup() {
~SYSVIPC
~!LOCKDEP
~!SLUB_DEBUG_ON
- ~!X86_KERNEL_IBT
!DEBUG_MUTEXES"
+
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
- to be fixed but, *if* modules fail to load, then try to either unset
- or pass ibt=off to the kernel (ignore this message otherwise)"
+
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, should be fine but *if* modules
+ fail to load with ENDBR errors, then try to either unset or pass ibt=off
+ to the kernel (default if no CPU support). Ignore this otherwise." # bug 911142
+ use kernel-open || CONFIG_CHECK+=" ~!X86_KERNEL_IBT"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-535.86.05.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-535.86.05.ebuild
index 27398ab95124..a029fdff14f9 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-535.86.05.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-535.86.05.ebuild
@@ -102,16 +102,18 @@ pkg_setup() {
~SYSVIPC
~!LOCKDEP
~!SLUB_DEBUG_ON
- ~!X86_KERNEL_IBT
!DEBUG_MUTEXES"
+
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
- to be fixed but, *if* modules fail to load, then try to either unset
- or pass ibt=off to the kernel (ignore this message otherwise)"
+
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, should be fine but *if* modules
+ fail to load with ENDBR errors, then try to either unset or pass ibt=off
+ to the kernel (default if no CPU support). Ignore this otherwise." # bug 911142
+ use kernel-open || CONFIG_CHECK+=" ~!X86_KERNEL_IBT"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764