summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-10 00:13:17 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-10 00:14:18 +1000
commit8c10f372034429929493b573315e3a29e07b2cd9 (patch)
treea5c7678eab2e98606d5c6834c39ab78ce4e2a7bb /x11-apps
parentprofiles: mask x11-apps/python-whiteboard for removal (diff)
downloadgentoo-8c10f372034429929493b573315e3a29e07b2cd9.tar.gz
gentoo-8c10f372034429929493b573315e3a29e07b2cd9.tar.bz2
gentoo-8c10f372034429929493b573315e3a29e07b2cd9.zip
x11-apps/fusion-icon: version bump 0.2.4
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/fusion-icon/Manifest1
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.2.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-apps/fusion-icon/Manifest b/x11-apps/fusion-icon/Manifest
index e6d452d59735..a2d1a4cc3f78 100644
--- a/x11-apps/fusion-icon/Manifest
+++ b/x11-apps/fusion-icon/Manifest
@@ -1 +1,2 @@
DIST fusion-icon-0.1.tar.gz 30508 SHA256 2e6757fd4fb8ed7d1640fcabfbe10a39f36cf41504eda0dd13605db70273fe79 SHA512 0c22d0c7a22a9c20f1285114f8b785aff6cf863d4fe3ea1198618b13d7144f459f131dccf885442908fcd82ab4ff69e5fc42e95314836725b0e51fa3190c2bcc WHIRLPOOL 7534f46df3965aa963a95b4ec796c5ef99980c9640a6d0ced6a542d5b22430b9c996d11236bbdf1c8f9f9b00bcf4346e9aaca85da571a81c16777c4e33b3b719
+DIST fusion-icon-0.2.4.tar.xz 29264 SHA256 0ebc6df6a9e839a50073221bb051400b3f472b707cac094766ccee8787812297 SHA512 dbdc68abef3ed243db30a72f367dc0ed8f875fa614c85e24235cbf06a8e1433bc30b175d43abbd8b5adf3150275f619a992602f1475cbdf235ae9cd9e1545848 WHIRLPOOL b618d49e676c941117ee48800ee51c79c2123eb5c77537dd960f516f4fc70c52b491a17b4cac18a10454c8cf3944dad44b24189a95b312a7127ef65b59fbb927
diff --git a/x11-apps/fusion-icon/fusion-icon-0.2.4.ebuild b/x11-apps/fusion-icon/fusion-icon-0.2.4.ebuild
new file mode 100644
index 000000000000..16d202465323
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz.org"
+SRC_URI="https://github.com/compiz-reloaded/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk qt5"
+
+REQUIRED_USE="|| ( gtk qt5 )"
+
+RDEPEND="
+ dev-python/compizconfig-python[${PYTHON_USEDEP}]
+ x11-apps/xvinfo
+ x11-wm/compiz
+ gtk? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )
+ qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+python_configure_all() {
+ esetup.py build \
+ $(use gtk && echo --with-gtk=3) \
+ $(use qt5 && echo --with-qt=5)
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}