summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-18 21:43:46 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-20 21:03:05 +0200
commite8f023d8e90b629c4b2fd580525b326a3a540aff (patch)
tree37caef0f62b4ead4b5899f05bcc38832c9dfd957 /www-servers
parentacct-user/thttpd: add user (155) thttpd (diff)
downloadgentoo-e8f023d8e90b629c4b2fd580525b326a3a540aff.tar.gz
gentoo-e8f023d8e90b629c4b2fd580525b326a3a540aff.tar.bz2
gentoo-e8f023d8e90b629c4b2fd580525b326a3a540aff.zip
www-servers/thttpd: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781548 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thttpd/thttpd-2.27.1-r2.ebuild67
-rw-r--r--www-servers/thttpd/thttpd-9999.ebuild40
2 files changed, 81 insertions, 26 deletions
diff --git a/www-servers/thttpd/thttpd-2.27.1-r2.ebuild b/www-servers/thttpd/thttpd-2.27.1-r2.ebuild
new file mode 100644
index 000000000000..bab74ced7884
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.27.1-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://github.com/blueness/sthttpd.git"
+ inherit git-r3
+else
+ MY_P="s${P}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/blueness/sthttpd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver"
+HOMEPAGE="https://github.com/blueness/sthttpd http://opensource.dyc.edu/sthttpd"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+RDEPEND="
+ acct-group/thttpd
+ acct-user/thttpd
+ virtual/libcrypt:=
+"
+DEPEND="${RDEPEND}"
+
+WEBROOT="/var/www/localhost"
+
+src_prepare() {
+ eapply "${FILESDIR}"/thttpd-renamed-htpasswd.patch
+ mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
+ eapply_user
+ eautoreconf -f -i
+}
+
+src_configure() {
+ econf WEBDIR="${EPREFIX}/${WEBROOT}/htdocs"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/thttpd.init.1 thttpd
+ newconfd "${FILESDIR}"/thttpd.confd.1 thttpd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/thttpd.logrotate" thttpd
+
+ insinto /etc/thttpd
+ doins "${FILESDIR}"/thttpd.conf.sample
+
+ # move htdocs to docdir, bug #429632
+ docompress -x /usr/share/doc/"${PF}"/htdocs.dist
+ mv "${ED}"/${WEBROOT}/htdocs "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
+ mkdir "${ED}"/${WEBROOT}/htdocs || die
+
+ keepdir ${WEBROOT}/htdocs
+
+ chown root:thttpd "${ED}/usr/sbin/makeweb" || die
+ chmod 2751 "${ED}/usr/sbin/makeweb" || die
+ chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" || die
+}
diff --git a/www-servers/thttpd/thttpd-9999.ebuild b/www-servers/thttpd/thttpd-9999.ebuild
index 4a0042d502cb..d26b6c0b54f5 100644
--- a/www-servers/thttpd/thttpd-9999.ebuild
+++ b/www-servers/thttpd/thttpd-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit autotools flag-o-matic toolchain-funcs user
+inherit autotools flag-o-matic toolchain-funcs
if [[ ${PV} = 9999* ]]
then
@@ -22,23 +22,15 @@ HOMEPAGE="https://github.com/blueness/sthttpd http://opensource.dyc.edu/sthttpd"
LICENSE="BSD GPL-2"
SLOT="0"
-RDEPEND="virtual/libcrypt:="
+RDEPEND="
+ acct-group/thttpd
+ acct-user/thttpd
+ virtual/libcrypt:=
+"
DEPEND="${RDEPEND}"
WEBROOT="/var/www/localhost"
-THTTPD_USER=thttpd
-THTTPD_GROUP=thttpd
-THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"
-
-DOCS=( TODO )
-
-pkg_setup() {
- ebegin "Creating thttpd user and group"
- enewgroup ${THTTPD_GROUP}
- enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
-}
-
src_prepare() {
eapply "${FILESDIR}"/thttpd-renamed-htpasswd.patch
mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
@@ -47,7 +39,7 @@ src_prepare() {
}
src_configure() {
- econf WEBDIR=${THTTPD_DOCROOT}
+ econf WEBDIR="${EPREFIX}/${WEBROOT}/htdocs"
}
src_install() {
@@ -62,18 +54,14 @@ src_install() {
insinto /etc/thttpd
doins "${FILESDIR}"/thttpd.conf.sample
- #move htdocs to docdir, bug #429632
+ # move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
- mv "${ED}"${WEBROOT}/htdocs \
- "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
- mkdir "${ED}"${WEBROOT}/htdocs || die
+ mv "${ED}"/${WEBROOT}/htdocs "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
+ mkdir "${ED}"/${WEBROOT}/htdocs || die
keepdir ${WEBROOT}/htdocs
- chown root:${THTTPD_GROUP} "${ED}/usr/sbin/makeweb" \
- || die "Failed chown makeweb"
- chmod 2751 "${ED}/usr/sbin/makeweb" \
- || die "Failed chmod makeweb"
- chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" \
- || die "Failed chmod printenv"
+ chown root:thttpd "${ED}/usr/sbin/makeweb" || die
+ chmod 2751 "${ED}/usr/sbin/makeweb" || die
+ chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" || die
}