summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /www-servers/gatling
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'www-servers/gatling')
-rw-r--r--www-servers/gatling/gatling-0.15.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/www-servers/gatling/gatling-0.15.ebuild b/www-servers/gatling/gatling-0.15.ebuild
index b404cfd8a5c9..ba78c1bb2f64 100644
--- a/www-servers/gatling/gatling-0.15.ebuild
+++ b/www-servers/gatling/gatling-0.15.ebuild
@@ -41,21 +41,20 @@ src_compile() {
emake DIET="${DIET}" CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} -I${ROOT}usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets} \
- || die "emake ${targets} failed"
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
}
src_install() {
- doman gatling.1 || die "installing manpage failed"
+ doman gatling.1
- newconfd "${FILESDIR}/gatling.confd" gatling || die
- newinitd "${FILESDIR}/gatling.initd-3" gatling || die
- dodoc README.{ftp,http} || die "installing docs failed"
+ newconfd "${FILESDIR}/gatling.confd" gatling
+ newinitd "${FILESDIR}/gatling.initd-3" gatling
+ dodoc README.{ftp,http}
- dobin gatling || die "installing gatling binary failed"
+ dobin gatling
use ssl && {
- dodoc README.tls || die "installing docs failed"
- dobin tlsgatling || die "installing tlsgatling binary failed"
+ dodoc README.tls
+ dobin tlsgatling
}
}