summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-10-24 14:41:38 +1000
committerMatt Jolly <kangie@gentoo.org>2024-10-24 14:43:24 +1000
commit13141c5b605867b553c5033a26f1408e541f7ea7 (patch)
treeced614e20083715b271ea2ce0f548405a2bef1fa /www-client
parentdev-python/pydantic-core: Bump to 2.25.0 (diff)
downloadgentoo-13141c5b605867b553c5033a26f1408e541f7ea7.tar.gz
gentoo-13141c5b605867b553c5033a26f1408e541f7ea7.tar.bz2
gentoo-13141c5b605867b553c5033a26f1408e541f7ea7.zip
www-client/dillo: fix GCC-15 warning
Noticed that this had been patched upstream when I went to log an issue. Also actually apply the `remove-which` patch. Closes: https://bugs.gentoo.org/939137 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/dillo-3.1.1.ebuild5
-rw-r--r--www-client/dillo/files/dillo-3.1.1-remove-which.patch11
-rw-r--r--www-client/dillo/files/dillo-3.1.1-unused-constructor.patch57
3 files changed, 62 insertions, 11 deletions
diff --git a/www-client/dillo/dillo-3.1.1.ebuild b/www-client/dillo/dillo-3.1.1.ebuild
index 9ad9d9bdc955..3b763bb84d26 100644
--- a/www-client/dillo/dillo-3.1.1.ebuild
+++ b/www-client/dillo/dillo-3.1.1.ebuild
@@ -54,6 +54,11 @@ BDEPEND="
DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+PATCHES=(
+ "${FILESDIR}"/${P}-unused-constructor.patch
+ "${FILESDIR}"/${P}-remove-which.patch
+)
+
src_prepare() {
default
eautoreconf
diff --git a/www-client/dillo/files/dillo-3.1.1-remove-which.patch b/www-client/dillo/files/dillo-3.1.1-remove-which.patch
index c79f522cbb2a..ea645bc0e4e6 100644
--- a/www-client/dillo/files/dillo-3.1.1-remove-which.patch
+++ b/www-client/dillo/files/dillo-3.1.1-remove-which.patch
@@ -3,17 +3,6 @@ From: meat <meat@device.domain>
Date: Thu, 3 Oct 2024 12:48:31 +0200
Subject: [PATCH] Use command -v instead of which
---- a/autogen.sh
-+++ b/autogen.sh
-@@ -15,7 +15,7 @@
- # Required binaries check
- #
- check_bin_file(){
-- which $1 > /dev/null 2>&1
-+ command -v $1 > /dev/null 2>&1
- if [ $? = 0 ]; then
- return 0
- else
--- a/configure.ac
+++ b/configure.ac
@@ -297,18 +297,18 @@ if test "x$enable_png" = "xyes"; then
diff --git a/www-client/dillo/files/dillo-3.1.1-unused-constructor.patch b/www-client/dillo/files/dillo-3.1.1-unused-constructor.patch
new file mode 100644
index 000000000000..60c984e18c8e
--- /dev/null
+++ b/www-client/dillo/files/dillo-3.1.1-unused-constructor.patch
@@ -0,0 +1,57 @@
+https://github.com/dillo-browser/dillo/commit/f3d7483ab4b1751944907fa24a260f0afbb60633.patch
+From: Rodrigo Arias Mallo <rodarima@gmail.com>
+Date: Thu, 17 Oct 2024 10:32:49 +0200
+Subject: [PATCH] Remove unused NotSoSimpleVector constructor
+
+Fixes: https://github.com/dillo-browser/dillo/issues/281
+See: https://bugs.gentoo.org/939137
+--- a/lout/misc.hh
++++ b/lout/misc.hh
+@@ -1,3 +1,23 @@
++/*
++ * Dillo Widget
++ *
++ * Copyright 2005-2007 Sebastian Geerken <sgeerken@dillo.org>
++ * Copyright 2024 Rodrigo Arias Mallo <rodarima@gmail.com>
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 3 of the License, or
++ * (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program. If not, see <http://www.gnu.org/licenses/>.
++ */
++
+ #ifndef __LOUT_MISC_HH__
+ #define __LOUT_MISC_HH__
+
+@@ -374,23 +394,6 @@ public:
+ this->startExtra = -1;
+ }
+
+- inline NotSoSimpleVector (const NotSoSimpleVector &o)
+- {
+- this->arrayMain = NULL;
+- this->numMain = o.numMain;
+- this->numAllocMain = o.numAllocMain;
+- resizeMain ();
+- memcpy (this->arrayMain, o.arrayMain, sizeof (T) * numMain);
+-
+- this->arrayExtra = NULL;
+- this->numExtra = o.numExtra;
+- this->numAllocExtra = o.numAllocExtra;
+- resizeExtra ();
+- memcpy (this->arrayExtra, o.arrayExtra, sizeof (T) * numExtra);
+-
+- this->startExtra = o.startExtra;
+- }
+-
+ inline ~NotSoSimpleVector ()
+ {
+ if (this->arrayMain)