summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-22 08:03:25 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-22 08:28:00 -0400
commit0aa673fe2b450a8eaa43d718b85cba6134fbb079 (patch)
tree128190bbf6dd3db909a4bcdad55c95123d6f10d1 /www-client
parentdev-python/django-registration: fix dep and enable test (diff)
downloadgentoo-0aa673fe2b450a8eaa43d718b85cba6134fbb079.tar.gz
gentoo-0aa673fe2b450a8eaa43d718b85cba6134fbb079.tar.bz2
gentoo-0aa673fe2b450a8eaa43d718b85cba6134fbb079.zip
www-client/qutebrowser: update live
Now defaults to Qt6 and auto-fallbacks to Qt5 if missing or broken, but there is little reason to use automagic in our case and it should use the backend ebuild set dependencies for (users can still override this at runtime if really wanted). Using sed is what machinery.py suggests. On a side-note, selected qt6 tests currently pass and qt5 has one failure. Will be reviewed further on release. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 2a80f2b1aa5d..0e11fd896ab8 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -88,11 +88,9 @@ src_prepare() {
-i ${PN}/config/qtargs.py || die
fi
- # default to the requested Qt backend, current default is PyQt5 but
- # sed unconditionally for safety in 9999 given this is going to change
- # (note that using sed is the suggested solution by upstream for now)
- sed -e "/^_DEFAULT_WRAPPER =/s/=.*/= \"PyQt$(usex qt6 6 5)\"/" \
- -i ${PN}/qt/machinery.py || die
+ # ensure the requested backend is used in case multiple are available
+ sed -e "/^_WRAPPER_OVERRIDE =/s/None/\"PyQt$(usex qt6 6 5)\"/" \
+ -i qutebrowser/qt/machinery.py || die
# let eclass handle python
sed -i '/setup.py/d' misc/Makefile || die
@@ -130,9 +128,12 @@ python_test() {
# not worth running dbus over
tests/unit/browser/test_notification.py::TestDBus
# bug 819393
- tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
- # tests that don't know about our newer qtwebengine:5
+ tests/unit/commands/test_userscripts.py::test_custom_env\[_POSIXUserscriptRunner\]
+ # test does not know about our newer fixed qtwebengine:5
tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
+ # needs _WRAPPER_OVERRIDE = None, but we have changed it
+ tests/unit/test_qt_machinery.py::TestSelectWrapper::test_autoselect_by_default
+ tests/unit/test_qt_machinery.py::TestInit::test_none_available_{implicit,explicit}
)
# qtargs are mangled with widevine+prefix
use widevine && use prefix && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )