summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPF4Public <PF4Public@users.noreply.github.com>2023-07-16 18:03:09 +0300
committerCraig Andrews <candrews@gentoo.org>2023-07-17 16:07:14 -0400
commit5503558262905060a10f2901f55a9410ab67b18d (patch)
tree9d78f7ea6b4985e75f9ee76641bb5a452c69382e /www-apps
parentacct-user/lidarr: new package lidarr (diff)
downloadgentoo-5503558262905060a10f2901f55a9410ab67b18d.tar.gz
gentoo-5503558262905060a10f2901f55a9410ab67b18d.tar.bz2
gentoo-5503558262905060a10f2901f55a9410ab67b18d.zip
www-apps/lidarr: new package
Signed-off-by: PF4Public <PF4Public@users.noreply.github.com> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/lidarr/Manifest3
-rw-r--r--www-apps/lidarr/files/lidarr.init7
-rw-r--r--www-apps/lidarr/files/lidarr.logrotate4
-rw-r--r--www-apps/lidarr/files/lidarr.service30
-rw-r--r--www-apps/lidarr/lidarr-1.3.1.3371.ebuild58
-rw-r--r--www-apps/lidarr/metadata.xml16
6 files changed, 118 insertions, 0 deletions
diff --git a/www-apps/lidarr/Manifest b/www-apps/lidarr/Manifest
new file mode 100644
index 000000000000..9b1fb85ac024
--- /dev/null
+++ b/www-apps/lidarr/Manifest
@@ -0,0 +1,3 @@
+DIST Lidarr.develop.1.3.1.3371.linux-core-arm.tar.gz 91228972 BLAKE2B 6b87e65ac7b52fef45bec48cec21090295fc32161d2495be8a1dad4765649170a682f4a388bd92c4bb44ad8304b939354c0b0cda27c37e0dae0438b88cef402b SHA512 9609d305599720580ea5b552b6de9e09c38384c4259915559fc6658a62ea6a2808a63568a276d5aa9aad890f4ceba5c92be74e8decb3df046c73f8af75f8bb3f
+DIST Lidarr.develop.1.3.1.3371.linux-core-arm64.tar.gz 90849747 BLAKE2B fe9203b61e2567b3b61a80ea9187847221871903af5d8a7574e0140e14087aabeb254b7b0829863e127035b9fb0090b601e59406c757c0a9e2524cbf6b0d6c4a SHA512 9c4206631d87490bd9582e52ec6aa037f2a9d7b6fcf0e8a560279fce1a18393b7049c426fe366979b87ba826be78161a0908d1ea1af60eec55a0cccc83beb37b
+DIST Lidarr.develop.1.3.1.3371.linux-core-x64.tar.gz 97348413 BLAKE2B cf2de430be5ecc88b624663a3e02d167714dc1bc72c18fc6b72936c1dfd5a70dae1671ab734d93fada1fcd1d2c4b7fdf1525289faf865fc0d9a2336b1ecbee95 SHA512 5286e5c628f4742df15acc72e9be62b8481b97495d677350fb53f03db3aff132e83d7a5dcaa65b39fa9f9d16bd473be0bfdd5971993b2659b577830ddada95e3
diff --git a/www-apps/lidarr/files/lidarr.init b/www-apps/lidarr/files/lidarr.init
new file mode 100644
index 000000000000..f68e0eb006a6
--- /dev/null
+++ b/www-apps/lidarr/files/lidarr.init
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+
+pidfile="/run/lidarr.pid"
+command="/opt/lidarr/Lidarr"
+command_user="lidarr:lidarr"
+command_background=true
+
diff --git a/www-apps/lidarr/files/lidarr.logrotate b/www-apps/lidarr/files/lidarr.logrotate
new file mode 100644
index 000000000000..abd09ad04336
--- /dev/null
+++ b/www-apps/lidarr/files/lidarr.logrotate
@@ -0,0 +1,4 @@
+/var/lib/lidarr/.config/lidarr/logs/*.txt{
+ missingok
+ su lidarr lidarr
+}
diff --git a/www-apps/lidarr/files/lidarr.service b/www-apps/lidarr/files/lidarr.service
new file mode 100644
index 000000000000..a4690d6f4cfa
--- /dev/null
+++ b/www-apps/lidarr/files/lidarr.service
@@ -0,0 +1,30 @@
+[Unit]
+Description=Looks and smells like Sonarr but made for music.
+After=syslog.target network.target
+
+[Service]
+User=lidarr
+Group=lidarr
+
+Type=simple
+ExecStart=/opt/lidarr/Lidarr
+TimeoutStopSec=20
+KillMode=process
+Restart=always
+
+PrivateTmp=yes
+PrivateDevices=yes
+PrivateMounts=yes
+ProtectHome=yes
+ProtectSystem=full
+NoNewPrivileges=yes
+ProtectHostname=yes
+ProtectClock=yes
+ProtectKernelTunables=yes
+ProtectKernelModules=yes
+ProtectKernelLogs=yes
+ProtectControlGroups=yes
+RestrictRealtime=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/www-apps/lidarr/lidarr-1.3.1.3371.ebuild b/www-apps/lidarr/lidarr-1.3.1.3371.ebuild
new file mode 100644
index 000000000000..47d13184e338
--- /dev/null
+++ b/www-apps/lidarr/lidarr-1.3.1.3371.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="
+ amd64? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-x64.tar.gz )
+ arm? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-arm.tar.gz )
+ arm64? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-arm64.tar.gz )
+"
+
+DESCRIPTION="Looks and smells like Sonarr but made for music"
+HOMEPAGE="https://lidarr.audio"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/lidarr
+ acct-user/lidarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+ sys-libs/glibc
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Lidarr"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Lidarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/lidarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/lidarr.service"
+ systemd_newunit "${FILESDIR}/lidarr.service" "${PN}@.service"
+}
diff --git a/www-apps/lidarr/metadata.xml b/www-apps/lidarr/metadata.xml
new file mode 100644
index 000000000000..002d5485d503
--- /dev/null
+++ b/www-apps/lidarr/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Lidarr/Lidarr</remote-id>
+ <bugs-to>https://github.com/Lidarr/Lidarr/issues</bugs-to>
+ </upstream>
+</pkgmetadata>