summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-08-29 21:36:52 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-08-29 21:36:52 +0300
commit516b085e012fc4f900c55dc24b42343b69b9661b (patch)
tree7d643949ca4b8fb35d2843088335d3d4a000fa66 /www-apps
parentnet-libs/webkit-gtk: Stabilize 2.40.5-r600 arm, #913218 (diff)
downloadgentoo-516b085e012fc4f900c55dc24b42343b69b9661b.tar.gz
gentoo-516b085e012fc4f900c55dc24b42343b69b9661b.tar.bz2
gentoo-516b085e012fc4f900c55dc24b42343b69b9661b.zip
www-apps/wordpress: add 6.3.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-6.3.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 33c456265ea7..d3a5966d72c5 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
+DIST wordpress-6.3.1.tar.gz 23447259 BLAKE2B 081662cab27632410b69cfbae6dad8e14119125f0fcaecf7b48c3d53659996569fd742b181daf2ef8aabcd5a8fe1487aec5e6934c017aa2298db74e1df820d44 SHA512 786abd032f2c245f2af4974a3b11cfbc541754a12cbb1bfa2339ab68b469711d5d8bf9394ff12fd7b6b7a5b4006d72aeecd34dc8fbed531b39df287e878e2da9
DIST wordpress-6.3.tar.gz 23445410 BLAKE2B 869f019166e1a5dc87eecfcd5dc8d95975811bfe64ec7bf1216ebe57e6e1362091f7e7b9e8342f55e991d5fd1856c6aad2cfc1e1a52b149248d9ea94bd378a13 SHA512 b9b2fa19efb8a352cd53a16de6baa492e201d8607d4a07758146d9b40b09dd40172d7292cd6ca21be92799e2b40763a537f63c8506da7b99acc5d144196b0566
diff --git a/www-apps/wordpress/wordpress-6.3.1.ebuild b/www-apps/wordpress/wordpress-6.3.1.ebuild
new file mode 100644
index 000000000000..b6c209d75a8c
--- /dev/null
+++ b/www-apps/wordpress/wordpress-6.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2+"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}