summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-11-10 15:49:26 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-01-11 16:05:46 +0200
commit7750c336910bca86643453f14d0f1bb446edd617 (patch)
treea2947e15b6af8ff57d33aa7e1cea81cc769b311c /www-apache
parentwww-apache/modsecurity-crs: drop vulnerable (diff)
downloadgentoo-7750c336910bca86643453f14d0f1bb446edd617.tar.gz
gentoo-7750c336910bca86643453f14d0f1bb446edd617.tar.bz2
gentoo-7750c336910bca86643453f14d0f1bb446edd617.zip
www-apache/modsecurity-crs: add 4.0.0-rc2
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33756 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-4.0.0_rc2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index a078ff818686..12a8f2c8714f 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -1 +1,2 @@
DIST modsecurity-crs-3.3.5.tar.gz 299458 BLAKE2B b8617de77cf5168c7b95fab46eae45e2101b4ec7a537d8d471b9b1b27a856b1d370a9de43ee262c07dc9371b3ff79cd86b7328b171fde003da9110897206e91e SHA512 001f9afe25f479dd988aaec1a4a2c0197b2d27e00d2cd10b70892e4889b399259cd0655f42a96965ae655855abdb7f9d8295c225ae17bf1e47361b70232633e5
+DIST modsecurity-crs-4.0.0_rc2.tar.gz 491479 BLAKE2B 71a016b7e45a991373357ece9cc7a59afe54daf91ffa826b76fd4a986b6e8989efb54ca3b83fac9307cf6ede1e1f7a78f9534cc5682e63ea3d75b9092c295d30 SHA512 302129aa3c476afd84b41bfdf73afaa1561f300ecad6ea3540d977639dc3c2167169298fbbe453ceb108d10dee3835b2e4f30f0c12cc413d3acd530906123021
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-4.0.0_rc2.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-4.0.0_rc2.ebuild
new file mode 100644
index 000000000000..1a0a134d3046
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-4.0.0_rc2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/coreruleset-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2"
+
+RDEPEND="apache2? ( >=www-apache/mod_security-2.9.6 )"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md crs-setup.conf.example KNOWN_BUGS.md README.md )
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r plugins rules
+
+ einstalldocs
+
+ if use apache2; then
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+ fi
+
+ optfeature "apache-less installations, e.g. nginx" dev-libs/modsecurity
+}