summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-14 11:47:47 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-14 11:48:49 +0200
commit478d54e622957553643acbcfa7ba97e94abdb1e0 (patch)
tree80e37ab425a6f62d05e6502b206663462c394df9 /www-apache
parentnet-p2p/biglybt: CP_DEPEND on swt:4.27[cairo] (diff)
downloadgentoo-478d54e622957553643acbcfa7ba97e94abdb1e0.tar.gz
gentoo-478d54e622957553643acbcfa7ba97e94abdb1e0.tar.bz2
gentoo-478d54e622957553643acbcfa7ba97e94abdb1e0.zip
www-apache/passenger: use correct ranlib version
Also remove some obsolete (now no-op) sed code. Closes: https://bugs.gentoo.org/727144 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/passenger-6.0.23.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/www-apache/passenger/passenger-6.0.23.ebuild b/www-apache/passenger/passenger-6.0.23.ebuild
index 0c0ad6d0d23f..8bbe3af9b847 100644
--- a/www-apache/passenger/passenger-6.0.23.ebuild
+++ b/www-apache/passenger/passenger-6.0.23.ebuild
@@ -45,14 +45,9 @@ pkg_setup() {
all_ruby_prepare() {
eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
# Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+ sed -e '/debugging_\(c\|cxx\)flags/areturn ""' \
+ -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
# Use sed here so that we can dynamically set the documentation directory.
sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
@@ -68,8 +63,10 @@ all_ruby_prepare() {
# Make sure we use the system-provided version where possible
rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+ # Fix hard-coded use of AR and RANLIB
+ sed -e "s/ar cru/"$(tc-getAR)" cru/" \
+ -e "s/ranlib/"$(tc-getRANLIB)"/" \
+ -i build/support/cplusplus.rb || die
# Make sure apache support is not attempted with -apache2
if ! use apache2 ; then