summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-11-17 09:11:10 -0500
committerCraig Andrews <candrews@gentoo.org>2021-11-17 09:12:59 -0500
commit07dbd107323884fb08f4b832acc884a621662665 (patch)
tree9f97d9aaa305488fa0faa48630cdfaca04177d7e /www-apache
parentdev-python/pyopencl: add 2021.2.9 (diff)
downloadgentoo-07dbd107323884fb08f4b832acc884a621662665.tar.gz
gentoo-07dbd107323884fb08f4b832acc884a621662665.tar.bz2
gentoo-07dbd107323884fb08f4b832acc884a621662665.zip
www-apache/mod_h2: 2.0.0 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 01fe0da03383..b3f89ea411bc 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -2,3 +2,4 @@ DIST mod_h2-1.15.24.tar.gz 664134 BLAKE2B 37795ee308d62f74583d7e37c262fca2ba235f
DIST mod_h2-2.0.0-rc2.tar.gz 655944 BLAKE2B d96d9196359bd7f6fb593a148a08a974e82a5e296c893526501c3e6c60f36581bc89548098e5ff6e42428d400cd8b7b44787ea97f7d0dbcd7d4da1db19c25ac8 SHA512 2c41fbe3d780452507d15b88fafe62c3386de023cc22181b7f077dd72e9c7738b6671494ba6e9c59f09df740ec4ec76dc42a9188e294b7900c97f1975038c0e2
DIST mod_h2-2.0.0-rc3.tar.gz 656572 BLAKE2B 56001bb007ebb5114cd41c67e83221cc15d50e8ddc1d6ec5a512c26221577eea44bb5a74537bc39c6e50cc14ed6070177cf3ab0fff39d1c8f3147090a07aae0b SHA512 f236bb8aa137d8a3675938beae31e6cd27863b4fb91f9cb65d7704ecd977ecda08dc4c069a4c3be19cb64587a960dae69a0eed98d25f9e07ad223212bc208a51
DIST mod_h2-2.0.0-rc4.tar.gz 656579 BLAKE2B 112fe4d41e0ddf769c0e7141584be823fd2e9849d95ea077347750019451937886cc6b88d123e004ba2fb799a4f0eea069337eaaa9627e8c70f4b74fb1c8ff08 SHA512 c061f97ebb13793067194a9bb531231b6aa424d2962c380de3769f04e09da3cf3434dd496e81c5f83137ea48cf197a4ee66ce7985c426c2b0b23eb1670e0e888
+DIST mod_h2-2.0.0.tar.gz 662677 BLAKE2B caefb52696917646a773b378183261e14b7559b52ccfe99641f4ceb536bd908cda3888eed8ea447436073d53d9a5bd3a50bd05aaaa0b71ca52d94c3d7faa03d4 SHA512 95c3efd3b5cf2aab1c7bd47d72df43b2dc26757efc9d1452b8d654b50398073f414dfa70dfb2333c96c4c79649e868cff518040fccfb95cf6b44dfea73022d75
diff --git a/www-apache/mod_h2/mod_h2-2.0.0.ebuild b/www-apache/mod_h2/mod_h2-2.0.0.ebuild
new file mode 100644
index 000000000000..352e2e78dea4
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}