summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /sys-process
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/below/below-0.8.1-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-process/below/below-0.8.1-r1.ebuild b/sys-process/below/below-0.8.1-r1.ebuild
index 95c1f45c601e..9adeeff32e98 100644
--- a/sys-process/below/below-0.8.1-r1.ebuild
+++ b/sys-process/below/below-0.8.1-r1.ebuild
@@ -294,7 +294,7 @@ CRATES="
zstd@0.13.0
"
-RUST_USEDEP="rustfmt"
+RUST_REQ_USE="rustfmt"
inherit cargo systemd