summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-05-25 14:32:45 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-05-25 14:41:35 -0700
commitd243977905d623e4c817012d55daca18309ebdc4 (patch)
tree8a86759f6446d739541d26b39ada7e74af7cfe03 /sys-process/glances
parentgnome-extra/evolution-ews: add 3.52.2 (diff)
downloadgentoo-d243977905d623e4c817012d55daca18309ebdc4.tar.gz
gentoo-d243977905d623e4c817012d55daca18309ebdc4.tar.bz2
gentoo-d243977905d623e4c817012d55daca18309ebdc4.zip
sys-process/glances: add 4.0.6
Forward-port update check patch and convert (and remove) some install path sed's into a patch. Also drop the commented lists of unpackaged optfeature packages due to a bunch of upstream dependency changes. Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'sys-process/glances')
-rw-r--r--sys-process/glances/Manifest1
-rw-r--r--sys-process/glances/files/glances-4.0.6-disable-update-check.patch36
-rw-r--r--sys-process/glances/files/glances-4.0.6-doc-install-path.patch20
-rw-r--r--sys-process/glances/glances-4.0.6.ebuild62
4 files changed, 119 insertions, 0 deletions
diff --git a/sys-process/glances/Manifest b/sys-process/glances/Manifest
index 3dfc085c818f..4da0f33a02ad 100644
--- a/sys-process/glances/Manifest
+++ b/sys-process/glances/Manifest
@@ -1,3 +1,4 @@
DIST glances-3.3.0.gh.tar.gz 6143830 BLAKE2B 022a8bfc93f73f2c728af21553ca36535340129cc5fb6f539d6f282e9ffc7a2b88878c04345a47479241447c0f1329123f804677383688fa5857dd1a9978dc65 SHA512 ee238e39e69dce3e46df560f7be1287a87a0c9002242d7b381bc971e627a4c23f6102519d7f6864998adcc9be7cf8e68461579f2a88d15db86ad75878015a843
DIST glances-3.4.0.3.gh.tar.gz 6472143 BLAKE2B 5437d3daefd4d36e9b84481543cf8189964006d566a77506099bfe7748d37409d5fb2a3a8eb52c8eeef0efa469c2ca92db7a37a44625969aec822d1adf46dbb3 SHA512 f4960d7d23b52e249069b41fd9b20a4d6f56006a6998b1bfd341ef00628fa92c14503885ebbea6adeee6f926a6c6fb440c288e2c772d4536b2c2b49e4124a7a0
DIST glances-3.4.0.5.gh.tar.gz 6473711 BLAKE2B 510f379946eec914998cba32ffd66c6037bd85246cdae059d336b4a3330ba6e521aa3fef2099d88f08dbf3ed7e7c8537235850ad8f6882840fb811bcd8a82147 SHA512 aca140fedc2acc97ae4901722e0406acb8bea6eac5295d95499860a522e74d29ecbc4cfb28fecfd4a2879f4ee44175bd4efd2429b9d7e302b4a182caabd6a5f8
+DIST glances-4.0.6.gh.tar.gz 6622650 BLAKE2B 82290999d94ea46bb5671a6eb2959cbb4246dd231fddbb6ad72108d7270faf5a3da5f73f25d1bdb8987a6db79d7a07eb05581fa7b4d7406df97cffb274e20387 SHA512 d5bb804aff6dbc5147a185cb613ca9f402b43fc2d9bef1e80dfd90db3fe11f445aade0d73e987a9a3665c4bf4f210dd3d1a98e9b53e028ef4e49a9111b527f0d
diff --git a/sys-process/glances/files/glances-4.0.6-disable-update-check.patch b/sys-process/glances/files/glances-4.0.6-disable-update-check.patch
new file mode 100644
index 000000000000..aa8fbfc569bd
--- /dev/null
+++ b/sys-process/glances/files/glances-4.0.6-disable-update-check.patch
@@ -0,0 +1,36 @@
+From: John Helmert III <ajak@gentoo.org>
+Date: Sat, 25 May 2024 14:01:10 -0700
+Subject: [PATCH] disable runtime out-of-date check
+
+Signed-off-by: John Helmert III <ajak@gentoo.org>
+--- a/glances/standalone.py
++++ b/glances/standalone.py
+@@ -112,9 +112,6 @@ class GlancesStandalone:
+ # It is done in the screen.init function
+ self._quiet = args.quiet
+
+- # Check the latest Glances version
+- self.outdated = Outdated(config=config, args=args)
+-
+ @property
+ def quiet(self):
+ return self._quiet
+@@ -192,15 +189,3 @@ class GlancesStandalone:
+
+ # Exit from export modules
+ self.stats.end()
+-
+- # Check Glances version versus PyPI one
+- if self.outdated.is_outdated():
+- latest_version = self.outdated.latest_version()
+- installed_version = self.outdated.installed_version()
+- print(f"You are using Glances version {installed_version}, however version {latest_version} is available.")
+- print("You should consider upgrading using: pip install --upgrade glances")
+- print("Disable this warning temporarily using: glances --disable-check-update")
+- print(
+- "To disable it permanently, refer config reference at "
+- "https://glances.readthedocs.io/en/latest/config.html#syntax"
+- )
+--
+2.45.1
+
diff --git a/sys-process/glances/files/glances-4.0.6-doc-install-path.patch b/sys-process/glances/files/glances-4.0.6-doc-install-path.patch
new file mode 100644
index 000000000000..077cd0924c4b
--- /dev/null
+++ b/sys-process/glances/files/glances-4.0.6-doc-install-path.patch
@@ -0,0 +1,20 @@
+From b90ce653b99f4efa15e27f4a71a4e251d0b34d2c Mon Sep 17 00:00:00 2001
+From: John Helmert III <ajak@gentoo.org>
+Date: Sat, 25 May 2024 14:21:50 -0700
+Subject: [PATCH] setup.py: install docs to versioned directory
+
+Signed-off-by: John Helmert III <ajak@gentoo.org>
+--- a/setup.py
++++ b/setup.py
+@@ -31,7 +31,7 @@ with builtins.open('README.rst', encoding='utf-8') as f:
+ def get_data_files():
+ return [
+ (
+- 'share/doc/glances',
++ f'share/doc/glances-{version}',
+ ['AUTHORS', 'COPYING', 'NEWS.rst', 'README.rst', "SECURITY.md", 'CONTRIBUTING.md', 'conf/glances.conf'],
+ ),
+ ('share/man/man1', ['docs/man/glances.1']),
+--
+2.45.1
+
diff --git a/sys-process/glances/glances-4.0.6.ebuild b/sys-process/glances/glances-4.0.6.ebuild
new file mode 100644
index 000000000000..2988ea7d7c95
--- /dev/null
+++ b/sys-process/glances/glances-4.0.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 linux-info optfeature
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances"
+SRC_URI="https://github.com/nicolargo/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.4.3[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ ')
+"
+
+# PYTHON_USEDEP omitted on purpose
+BDEPEND="doc? ( dev-python/sphinx-rtd-theme )"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.6-disable-update-check.patch"
+ "${FILESDIR}/${PN}-4.0.6-doc-install-path.patch"
+)
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs --no-autodoc
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+python_test() {
+ "${EPYTHON}" unittest-core.py || echo "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Autodiscover mode" dev-python/zeroconf
+ optfeature "Cloud support" dev-python/requests
+ optfeature "Docker monitoring support" dev-python/docker
+ optfeature "SVG graph support" dev-python/pygal
+ optfeature "IP plugin" dev-python/netifaces
+ optfeature "RAID monitoring" dev-python/pymdstat
+ optfeature "RAID support" dev-python/pymdstat
+ optfeature "SNMP support" dev-python/pysnmp
+ optfeature "WIFI plugin" net-wireless/python-wifi
+}