summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-11-14 21:18:58 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-11-14 21:20:52 +0100
commitb948f45310d0722b90147c879f52a82e7ff05d0e (patch)
tree1b4efc98a5380672356f296f338ed2677ee7f003 /sys-power
parentsci-libs/caffe2: fix xnnpack use, add deps and other (diff)
downloadgentoo-b948f45310d0722b90147c879f52a82e7ff05d0e.tar.gz
gentoo-b948f45310d0722b90147c879f52a82e7ff05d0e.tar.bz2
gentoo-b948f45310d0722b90147c879f52a82e7ff05d0e.zip
sys-power/sandmann-bin: add 1.3.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/sandmann-bin/Manifest1
-rw-r--r--sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-power/sandmann-bin/Manifest b/sys-power/sandmann-bin/Manifest
index 9b57103ed034..af4f6453daa4 100644
--- a/sys-power/sandmann-bin/Manifest
+++ b/sys-power/sandmann-bin/Manifest
@@ -1 +1,2 @@
DIST sandmann-1.2.tar.xz 16868444 BLAKE2B b4e6bfefedc31af3b1fcb9c5b05349a23eb6150296dff6ee74a6626e6f6914a244bb7bb22ece4a28daa699f3291f1b7194307f1b524ed0c8ab924587e5b001f6 SHA512 44a3287f61361d0594988715ef8d302d772dbec40a50054c5091642cbba18ef006ddb59e52303f9482ddb66de6006ef340b3726be7486cdb40092302e5aa5501
+DIST sandmann-1.3.1.tar.xz 16884480 BLAKE2B 6e16eae03f7ab43d5c3807b43587dbf65047ed86196623748e499eba20d6347bd074ff6ed167f7301c7cfdc746654811428f16569bd1b8a6ebb3cb3b660cf7f0 SHA512 8aaead9ff9b711737eecff49edee042b32fdbc194b67f99a6bfbca6a8915442cd60d505ce070685915fa7aae6b0fecd7eb5c55096580bf3f8f525650eddbd8cc
diff --git a/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild b/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild
new file mode 100644
index 000000000000..601f1616d2cf
--- /dev/null
+++ b/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-utils-2 systemd tmpfiles
+
+MY_PN=${PN%-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An autosuspend and wakeup daemon"
+HOMEPAGE="https://gitlab.com/flow/sandmann"
+SRC_URI="https://geekplace.eu/projects/${MY_PN}/archive/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-3+ LGPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# >=java-config-2.3.2 to get the libdir fix.
+RDEPEND="
+ acct-user/sandmann
+ >=dev-java/java-config-2.3.2
+ sys-apps/systemd
+ sys-auth/polkit
+ >=virtual/jre-17
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|^ExecStart=.*|ExecStart=/usr/bin/sandmann|' \
+ sandmann.service || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local my_emake_args=(
+ DESTDIR="${D}"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+ TARGET_BINARY=
+ SOURCELESS_INSTALL=true
+ )
+
+ emake ${my_emake_args[@]} install
+
+ java-pkg_newjar out/main/assembly.dest/out.jar sandmann.jar
+ java-pkg_dolauncher sandmann
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ tmpfiles_process sandmann.conf
+}