summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2025-01-20 14:32:11 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2025-01-20 14:33:47 +0100
commit0da0587f87c4e6285d94e5794c0617805eacb331 (patch)
treeb648c608606d331add3f1b1422399d0d3cd46619 /sys-libs
parentmedia-sound/abcmidi: Stabilize 2024.12.16 amd64, #948442 (diff)
downloadgentoo-0da0587f87c4e6285d94e5794c0617805eacb331.tar.gz
gentoo-0da0587f87c4e6285d94e5794c0617805eacb331.tar.bz2
gentoo-0da0587f87c4e6285d94e5794c0617805eacb331.zip
sys-libs/glibc: copy libgcc_s.so.1 into testdir (needed e.g. for arm)
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 9622057c7724..ce1e17c086a8 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1295,6 +1295,16 @@ glibc_src_test() {
done
fi
+ # on some architectures, libsupport requires libgcc_s.so support for unwinding
+ # if it's not present then many tests fail
+
+ if tc-is-gcc ; then
+ local lgc=$(${CC} -print-libgcc-file-name)
+ lgc=${lgc/.a/_s.so.1}
+ einfo "Copying ${lgc} into build directory"
+ cp "${lgc}" ./ || die
+ fi
+
# sandbox does not understand unshare() and prevents
# writes to /proc/, which makes many tests fail