summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:27:01 +0200
commit17ecf87314e0445c155c7863367414e07748e0d4 (patch)
tree42ddc6e1a51860c8669d946167d097af602a7d07 /sys-libs/libcxxabi
parentsys-libs/llvm-libunwind: Modernize (diff)
downloadgentoo-17ecf87314e0445c155c7863367414e07748e0d4.tar.gz
gentoo-17ecf87314e0445c155c7863367414e07748e0d4.tar.bz2
gentoo-17ecf87314e0445c155c7863367414e07748e0d4.zip
sys-libs/libcxxabi: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/libcxxabi')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
index 577953191e5d..15858fc7fc75 100644
--- a/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
@@ -22,16 +22,22 @@ RDEPEND="
>=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
>=sys-libs/llvm-libunwind-3.9.0-r1[static-libs?,${MULTILIB_USEDEP}]
)
- )"
+ )
+"
# llvm-6 for new lit options
-DEPEND="${RDEPEND}
- >=sys-devel/llvm-6"
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/llvm-6
+"
BDEPEND="
- ${PYTHON_DEPS}
+ !test? (
+ ${PYTHON_DEPS}
+ )
test? (
>=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
- )"
+ )
+"
LLVM_COMPONENTS=( runtimes libcxx{abi,} llvm/cmake cmake )
LLVM_TEST_COMPONENTS=( llvm/utils/llvm-lit )