summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 16:09:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 22:33:07 +0200
commit3e8a1bc2c8975e06cbe70f6bda54468465b0fc9d (patch)
treeb0a0ab0a81854f747111133d93c971268d368f51 /sys-kernel
parentvirtual/dist-kernel: Bump to 6.10.8 (diff)
downloadgentoo-3e8a1bc2c8975e06cbe70f6bda54468465b0fc9d.tar.gz
gentoo-3e8a1bc2c8975e06cbe70f6bda54468465b0fc9d.tar.bz2
gentoo-3e8a1bc2c8975e06cbe70f6bda54468465b0fc9d.zip
sys-kernel/vanilla-kernel: Bump to 6.6.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.6.49.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 5e6f35909146..a51105d36364 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -38,3 +38,5 @@ DIST linux-6.6.47.tar.sign 989 BLAKE2B dc5b68309d03a9adb9e9721475517c495d44c1b9d
DIST linux-6.6.47.tar.xz 140308580 BLAKE2B ece3be3257b205c3d56c71525b95798347ab40b00d9ca54f0812a5407725512613075e85b3a6a0f3bfc4a59c714438efc4c08ed171a3f92e62cc3e4046f87a1f SHA512 9a3c52f5df4480a61493ca24d25c9e9b5b9dfe2e465ecf7d457bc240abf88b2d08d745b63895c6b47a557fca610882bbc8b5fe66b2d7a9262f548daca50d4004
DIST linux-6.6.48.tar.sign 989 BLAKE2B 855c0c89500fc0217531ccfa61774d50d69da28adf01eeef0ea1bc7d4ef805797c01f722b7e555685a8cb245db1a55fa01d53c969530c28528f465d736b93a35 SHA512 3c312aa5310ed0dcbbf94047be094f67511e1106521067ed9aa2ce722079163681768afa1cd937587b96a727c344ba33d974ad4e72a4e5b2301af8a54eb20f16
DIST linux-6.6.48.tar.xz 140310108 BLAKE2B 8c6435fbd16ae3fa8bc4703ddf6d57e8b12ea1fced14385a35e08750331de21e1709139517343fa71f018eb65658cde61c653c5b75d02add4599d6026040620a SHA512 4ed450e554218d971e64df0d934cf6e90740f0953376faf2ce20ea09857ff23c7ae144164d2bd10e93b67c22601fd2b9d64e27162235c6cc4cce932dd60d1cb9
+DIST linux-6.6.49.tar.sign 989 BLAKE2B 2ab6f62a7260f704c9b1ce6f62d95809ab6ef12832d246158e748d5882e311a72450d431ae9de1b14fc3fe42dd6421c83d4984d9a95f3564d59126ec627d1059 SHA512 5f61a4a48b2db6e7b024071a3475379246eb6290986a7876d50fb558345d083827ce264c1703507c3aee0b14f4fbaf6d429bc08a038fbb556845859b6fd6ec06
+DIST linux-6.6.49.tar.xz 140314800 BLAKE2B 2fdfdcfe27696540fc57b53ae45241d87291ab4f1467cf7b14d904b5da800565361b55e91344904bf6bb520a766b66cf9c4bbc26b656393dd96850a17c573807 SHA512 3db87b48dd3b771cd119cf48f9fbad43cfe2f90e34bb06419a25068a6807c294d2019089a21471b72c1438f45a84d99ecf77d322ef85b3e2815c7dedc6f41bd8
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.6.49.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.6.49.ebuild
new file mode 100644
index 000000000000..93587cc4db6d
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.6.49.ebuild
@@ -0,0 +1,137 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KERNEL_IUSE_MODULES_SIGN=1
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.6.12-gentoo
+GENTOO_CONFIG_VER=g13
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ arm | hppa | loong)
+ > .config || die
+ ;;
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ use secureboot && merge_configs+=( "${dist_conf_path}/secureboot.config" )
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}