summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-10-22 18:38:59 -0400
committerMike Pagano <mpagano@gentoo.org>2023-10-22 18:38:59 -0400
commit0fdd06d4f001ef05356a253273b9e3f52a2b42d1 (patch)
tree2caaf4f44d7b22e33412e5be89c098097901f32f /sys-kernel
parentdev-util/intel-graphics-system-controller: add version dep for metee (diff)
downloadgentoo-0fdd06d4f001ef05356a253273b9e3f52a2b42d1.tar.gz
gentoo-0fdd06d4f001ef05356a253273b9e3f52a2b42d1.tar.bz2
gentoo-0fdd06d4f001ef05356a253273b9e3f52a2b42d1.zip
sys-kernel/git-sources: add 6.6_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.6_rc7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index e2be5259316c..6cbe77392042 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-6.6-rc3.patch 39738774 BLAKE2B 0a49e4735de5f24d9cc6c898834b4c1d8fc947
DIST patch-6.6-rc4.patch 39983583 BLAKE2B 4ea2b64498c246b579f50b00b184203a86c17f3c22df052136459cd3e55dea8c8ebfcd6385251ebc6d8d9903bbd410faca9cf2efd1618c601ea3bd90653b667f SHA512 e5b18ad99c2d11d9d1f9506314bfd2356135730071f4299ac97bd1d868419fc04cb036dae2b8430adb416bc58b8bf618a6d86a01f4e07421dc9ea93b84e1e6d4
DIST patch-6.6-rc5.patch 40260669 BLAKE2B 54c4639c8d86fbbdf9e0e9898565280f6b1becd955e74a33545159835f4db7596d526601ce67299a218c7d9d7b5f80caad851567e73f71287b55cb7cf66b335c SHA512 088da15f8b098b93ce1c90403ab17ef3e40d1b69dcee8254427a61cf62fab7bbef61e2251255f87b7f8ca45a24b5b807b044204e5241fcd452a59d09f57f7fee
DIST patch-6.6-rc6.patch 40551984 BLAKE2B 7a8024b838cdc58f59db804cdfe359fb51706b328dd4a0707068fb36e7a85d4ef2196a85345539b773a01bec979a53b00131daa25ad3123620ff5a0cc7fd96f8 SHA512 f6a75af96d6030851f0f6c61b8400c23ca51b9f16cdd7093ad099e098e1f8280427a7e948f683486304e581062cfe0b5a87a347c2c7fc5d5a15a16a602411129
+DIST patch-6.6-rc7.patch 40806285 BLAKE2B 655e739eb6742c093056b886c91d89106fb4e55ed7a24abc07e85ff39e75f83b0c59e374a0f68cad8b975e33d5de37915df420a1c3ec93e4f24e59ee2da7f8f0 SHA512 c8e5c82aa09cb0e55eedbeee1e58bf461d5188d5e555d62101a182619ac315f3ca09bfd08d00c26b7fb900a4fca84d599c2e96c5afd909fe114395de57b8470a
diff --git a/sys-kernel/git-sources/git-sources-6.6_rc7.ebuild b/sys-kernel/git-sources/git-sources-6.6_rc7.ebuild
new file mode 100644
index 000000000000..5065c9cfd114
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.6_rc7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.5"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}