summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-29 22:26:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-29 22:36:46 +0200
commitbf414177055490c8dd5acc59db2eb595bd5f251e (patch)
tree685e0d1d297932f1110fdd9ffe5c051a44ed1faa /sys-fs
parentx11-terms/kitty: add 0.26.1, drop 0.26.0 (diff)
downloadgentoo-bf414177055490c8dd5acc59db2eb595bd5f251e.tar.gz
gentoo-bf414177055490c8dd5acc59db2eb595bd5f251e.tar.bz2
gentoo-bf414177055490c8dd5acc59db2eb595bd5f251e.zip
sys-fs/mp3fs: update EAPI 6 -> 8, fix dependencies
Bug: https://bugs.gentoo.org/732764 Closes: https://bugs.gentoo.org/798981 Closes: https://bugs.gentoo.org/809299 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mp3fs/mp3fs-1.1.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/mp3fs/mp3fs-1.1.1-r2.ebuild b/sys-fs/mp3fs/mp3fs-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..91cf99c844be
--- /dev/null
+++ b/sys-fs/mp3fs/mp3fs-1.1.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Read-only FUSE filesystem which transcodes FLAC audio files to MP3 when read"
+HOMEPAGE="https://khenriks.github.com/mp3fs/"
+SRC_URI="https://github.com/khenriks/mp3fs/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+flac vorbis"
+
+REQUIRED_USE="|| ( flac vorbis )"
+RESTRICT="test"
+
+DEPEND="
+ media-libs/libid3tag:=
+ media-sound/lame
+ sys-fs/fuse:0=
+ flac? ( >=media-libs/flac-1.1.4 )
+ vorbis? ( >=media-libs/libvorbis-1.3.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with flac) \
+ $(use_with vorbis)
+}