summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 12:51:05 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 13:00:11 +0100
commita9a132b4df2d619e92909da7ce4701c0e227dcd6 (patch)
tree8276e8b94d678a76930ba20cb7518ed309daf365 /sys-fs
parentdev-libs/sord: arm stable wrt bug #706050 (diff)
downloadgentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.tar.gz
gentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.tar.bz2
gentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.zip
sys-fs/squashfs-tools: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/706456 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.4-fno-common.patch11
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild11
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-9999.ebuild9
3 files changed, 21 insertions, 10 deletions
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.4-fno-common.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.4-fno-common.patch
new file mode 100644
index 000000000000..dfbf42abb34b
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-4.4-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/squashfs-tools/mksquashfs.h
++++ b/squashfs-tools/mksquashfs.h
+@@ -143,7 +143,7 @@ struct append_file {
+ #endif
+
+ extern struct cache *reader_buffer, *fragment_buffer, *reserve_cache;
+-struct cache *bwriter_buffer, *fwriter_buffer;
++extern struct cache *bwriter_buffer, *fwriter_buffer;
+ extern struct queue *to_reader, *to_deflate, *to_writer, *from_writer,
+ *to_frag, *locked_fragment, *to_process_frag;
+ extern struct append_file **file_mapping;
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
index ae823c3e1979..fcc3ce5bf79e 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,9 @@ DEPEND="
${RDEPEND}
static? ( ${LIB_DEPEND} )
"
-S=${WORKDIR}/${P}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4-fno-common.patch
+)
use10() { usex $1 1 0 ; }
@@ -55,12 +57,11 @@ src_configure() {
}
src_compile() {
- emake "${EMAKE_SQUASHFS_CONF[@]}"
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
}
src_install() {
- dobin mksquashfs unsquashfs
- cd ..
+ dobin ${PN}/{mksquashfs,unsquashfs}
dodoc ACKNOWLEDGEMENTS CHANGES README*
dodoc -r RELEASE-READMEs
}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
index 56e2a3332c0b..c5bf886e7767 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,12 +34,12 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-4.3-sysmacros.patch
+ "${FILESDIR}"/${PN}-4.4-fno-common.patch
)
use10() { usex $1 1 0 ; }
src_configure() {
- cd "${WORKDIR}"/${P}/${PN} || die
# set up make command line variables in EMAKE_SQUASHFS_CONF
EMAKE_SQUASHFS_CONF=(
@@ -57,11 +57,10 @@ src_configure() {
}
src_compile() {
- cd "${WORKDIR}"/${P}/${PN} || die
- emake "${EMAKE_SQUASHFS_CONF[@]}"
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
}
src_install() {
- dobin "${WORKDIR}"/${P}/${PN}/{mksquashfs,unsquashfs}
+ dobin ${PN}/{mksquashfs,unsquashfs}
dodoc CHANGES README RELEASE-READMEs/*
}