summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-10 14:34:02 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-10 14:34:23 +0100
commit430c71cb5a39799ec0dc511eebeb090b2bf99eba (patch)
tree6d9aef85d74851ff1796fe74ba39dd9bfb866569 /sys-fs/quota
parentsys-fs/quota: Bump to version 4.06 (diff)
downloadgentoo-430c71cb5a39799ec0dc511eebeb090b2bf99eba.tar.gz
gentoo-430c71cb5a39799ec0dc511eebeb090b2bf99eba.tar.bz2
gentoo-430c71cb5a39799ec0dc511eebeb090b2bf99eba.zip
sys-fs/quota: Removed old
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/Manifest1
-rw-r--r--sys-fs/quota/files/quota-4.04-Listen-on-a-TCP-socket.patch77
-rw-r--r--sys-fs/quota/files/quota-4.04-glibc226.patch43
-rw-r--r--sys-fs/quota/quota-4.04-r3.ebuild85
4 files changed, 0 insertions, 206 deletions
diff --git a/sys-fs/quota/Manifest b/sys-fs/quota/Manifest
index 32589367d8a6..54bfef226d50 100644
--- a/sys-fs/quota/Manifest
+++ b/sys-fs/quota/Manifest
@@ -1,3 +1,2 @@
-DIST quota-4.04.tar.gz 577303 BLAKE2B 8ee1e8f99b70f626ec051e4e9afe53c788b625a29f26afbe075039cf88dde9f6641c39e0ccfdbfcc6981fabe35e8fd15e7203989e9bbbdd1f1772949566531f6 SHA512 adc33863d2a966b4c46983fa3926e6b6ba75e260ed21bdff646584237840e6beb0dcfbfd2f655969aa5675c3c398ac2e483afb933f03f983756ebb3352d0eaad
DIST quota-4.05.tar.gz 577313 BLAKE2B ab0adc04a2bee46f5b4f528c3a1b7f1dfbfc93cc153aebef91cf563e0b03344479b4d465f7d91cfee60c533052f27ce54f24a937c0c1ec312a5fff763cb82bd1 SHA512 a13ca93fb6fad032cb032874dda2f5d792e619b41e89b481e6aaa4f06ac5774e2728b09dd625addfbe22efccb1d85892b093736084c72f75675a60df168b92f2
DIST quota-4.06.tar.gz 520448 BLAKE2B 2cbadeade228d0154f3a8d455cc1aa6e85c9ad7854007e3188c9035abe4d5fdbdf97985fd2fa6308f486ffbe60461e0fe1139f1ec0ca415ce08292d74e0ddde1 SHA512 cece46b8e3a82e8afcf8bfc9f6b310ec91afe034102cebc031bc7d7e04287fdbffb21ab1d3e6e1825175cffa4bad0a4ecbefec0efee028d961b14ac626d5c871
diff --git a/sys-fs/quota/files/quota-4.04-Listen-on-a-TCP-socket.patch b/sys-fs/quota/files/quota-4.04-Listen-on-a-TCP-socket.patch
deleted file mode 100644
index cf1bd4aad32f..000000000000
--- a/sys-fs/quota/files/quota-4.04-Listen-on-a-TCP-socket.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 31ecd29b3b3f51145fd78f63087c10e9fcadf999 Mon Sep 17 00:00:00 2001
-From: Steve Dickson <steved@redhat.com>
-Date: Tue, 22 May 2018 12:41:59 +0200
-Subject: [PATCH] Listen on a TCP socket
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-rpc.rquotad spins in libtirpc's rendezvous_request() on accepting TCP
-connections because the polled TCP socket is not listening:
-
-poll([{fd=4, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}, {fd=5,
- events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}, {fd=6,
- events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}, {fd=7,
- events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 4, -1) = 2 ([{fd=5,
- revents=POLLHUP}, {fd=7, revents=POLLHUP}])
-accept(5, 0x7ffe61698700, [128]) = -1 EINVAL (Invalid argument)
-accept(7, 0x7ffe61698700, [128]) = -1 EINVAL (Invalid argument)
-
-The polled descriptors are:
-
-rpc.rquot 21981 root 4u IPv4 80449159 0t0 UDP *:rquotad
-rpc.rquot 21981 root 5u sock 0,9 0t0 80449162 protocol: TCP
-rpc.rquot 21981 root 6u IPv6 80449165 0t0 UDP *:rquotad
-rpc.rquot 21981 root 7u sock 0,9 0t0 80449168 protocol: TCPv6
-
-That results into a high CPU usage just after staring rpc.rquotad
-process.
-
-This patch adds a listen() call to svc_create_sock()
-routine which is needed with libtirpc version of svc_tli_create()
-as well as a needed IPv6 setsockopt().
-
-Signed-off-by: Petr Písař <ppisar@redhat.com>
----
- svc_socket.c | 18 ++++++++++++++++++
- 1 file changed, 18 insertions(+)
-
-diff --git a/svc_socket.c b/svc_socket.c
-index 8a44604..d2e3abf 100644
---- a/svc_socket.c
-+++ b/svc_socket.c
-@@ -118,6 +118,15 @@ static int svc_create_sock(struct addrinfo *ai)
- return -1;
- }
-
-+ if (ai->ai_family == AF_INET6) {
-+ if (setsockopt(fd, IPPROTO_IPV6, IPV6_V6ONLY,
-+ &optval, sizeof(optval)) < 0) {
-+ errstr(_("Cannot set IPv6 socket options: %s\n"), strerror(errno));
-+ close(fd);
-+ return -1;
-+ }
-+ }
-+
- if (setsockopt(fd, SOL_SOCKET, SO_REUSEADDR, &optval, sizeof(optval)) < 0) {
- errstr(_("Cannot set socket options: %s\n"), strerror(errno));
- close(fd);
-@@ -129,6 +138,15 @@ static int svc_create_sock(struct addrinfo *ai)
- close(fd);
- return -1;
- }
-+
-+ if (ai->ai_protocol == IPPROTO_TCP) {
-+ if (listen(fd, SOMAXCONN) < 0) {
-+ errstr(_("Cannot listen to address: %s\n"), strerror(errno));
-+ close(fd);
-+ return -1;
-+ }
-+ }
-+
- return fd;
- }
-
---
-2.14.3
-
diff --git a/sys-fs/quota/files/quota-4.04-glibc226.patch b/sys-fs/quota/files/quota-4.04-glibc226.patch
deleted file mode 100644
index 5f63cde7d426..000000000000
--- a/sys-fs/quota/files/quota-4.04-glibc226.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From bbb8819fc0f6ed379a05d635a61bcf9c8986079f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
-Date: Sat, 16 Sep 2017 13:09:43 +0200
-Subject: [PATCH] Add $(TIRPC_CFLAGS) globally to CFLAGS for RPC support,
- needed for libc 2.26
-
----
- Makefile.am | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 8d80bee..278290a 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -51,6 +51,8 @@ EXTRA_DIST = \
- noinst_LIBRARIES = libquota.a
-
- if WITH_RPC
-+CFLAGS += $(TIRPC_CFLAGS)
-+
- rpcsvcdir = $(includedir)/rpcsvc
- rpcsvc_DATA = \
- rquota.h \
-@@ -100,8 +102,6 @@ libquota_a_SOURCES = \
- mntopt.h \
- pot.c \
- pot.h
--libquota_a_CFLAGS = \
-- $(TIRPC_CFLAGS)
- libquota_a_LIBADD = \
- $(RPCLIBS)
-
-@@ -235,7 +235,6 @@ rpc_rquotad_SOURCES = \
- rquota_server.c \
- rquota_svc.c \
- svc_socket.c
--rpc_rquotad_CFLAGS = $(TIRPC_CFLAGS)
- rpc_rquotad_LDADD = \
- libquota.a \
- $(WRAP_LIBS) \
---
-2.14.1
-
diff --git a/sys-fs/quota/quota-4.04-r3.ebuild b/sys-fs/quota/quota-4.04-r3.ebuild
deleted file mode 100644
index 9a208fb2b9a6..000000000000
--- a/sys-fs/quota/quota-4.04-r3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="ldap netlink nls rpc tcpd"
-
-RDEPEND="
- sys-fs/e2fsprogs
- ldap? ( >=net-nds/openldap-2.3.35 )
- netlink? (
- sys-apps/dbus
- dev-libs/libnl:3
- )
- rpc? (
- elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
- net-libs/libtirpc
- net-libs/rpcsvc-proto
- )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-PDEPEND="
- rpc? ( net-nds/rpcbind )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-glibc226.patch"
- "${FILESDIR}/${P}-Listen-on-a-TCP-socket.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-ext2direct
- $(use_enable nls)
- $(use_enable ldap ldapmail)
- $(use_enable netlink)
- $(use_enable rpc)
- $(use_enable rpc rpcsetquota)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/* README.* Changelog
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- newinitd "${FILESDIR}"/quota.rc7 quota
- newconfd "${FILESDIR}"/quota.confd quota
-
- if use rpc ; then
- newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema
- insopts -m0644
- doins "${FILESDIR}"/ldap-scripts/quota.schema
-
- exeinto /usr/share/quota/ldap-scripts
- doexe "${FILESDIR}"/ldap-scripts/*.pl
- doexe "${FILESDIR}"/ldap-scripts/edquota_editor
- fi
-}