summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-26 10:52:10 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-26 11:13:01 +0300
commit233276e2457c31e779bf491af2b5462c247831cf (patch)
treef4690678c18e28e89d9f010b5ed8687eaf70e206 /sys-fs/lxcfs
parentdev-libs/voikko-fi: add python-3.{8,9} support (diff)
downloadgentoo-233276e2457c31e779bf491af2b5462c247831cf.tar.gz
gentoo-233276e2457c31e779bf491af2b5462c247831cf.tar.bz2
gentoo-233276e2457c31e779bf491af2b5462c247831cf.zip
sys-fs/lxcfs: remove old 3.0.3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/lxcfs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/files/lxcfs-fusermount-path.patch15
-rw-r--r--sys-fs/lxcfs/files/lxcfs.initd26
-rw-r--r--sys-fs/lxcfs/lxcfs-3.0.3.ebuild72
4 files changed, 0 insertions, 114 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index e9d5038efe95..1eb6648b2c62 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,3 +1,2 @@
-DIST lxcfs-3.0.3.tar.gz 49824 BLAKE2B 02e3a0a6f4fd515924c5f038f00d664ef347c9b685e6561334b460e0ce0ce5580aca67f33df56b44b9cdafa4953f4f92843662f3516e1c923f9242388b17dbc6 SHA512 d994e1dd85f499eba2847d33870281a4bcaf4466e2c8f7acb065f4f3d5688b93b775c486bc6db571e64d09a3567710b0c816e12555ffb3e3e50f81bc7f5f6be6
DIST lxcfs-4.0.3.tar.gz 100719 BLAKE2B 24371b921ad635f97c51ac8406c949e81330ae358b0166c2af295cb1f630594bb72da802aad41971c11303f393fd05bc9f1b109bd4da4953db2c3bb7e5189315 SHA512 0aaedfe826d982b9464dfb60fb57c58e34ea6022b8503bc858538b6634dc7d0845f65832d6f814043dbc0677f887e1b559549a8f3865c755970c6b47ba65eb2b
DIST lxcfs-4.0.4.tar.gz 101546 BLAKE2B 1e84e3b75bfb39273539ea72f941442cc3c8574c0f55359a38edc04a98a45ea8680f9bf49c5974decf180a8ecf07cadccf4e732d1743c070a740c78b773a3ee8 SHA512 15bcebecc815310870aea58d995d605444b57583b7f1bb2d35b065256ea5f70b071d58887fbf1ca124ea84da99151bbd9dffcca37a2e151677d56229dc8961ce
diff --git a/sys-fs/lxcfs/files/lxcfs-fusermount-path.patch b/sys-fs/lxcfs/files/lxcfs-fusermount-path.patch
deleted file mode 100644
index 99a5addf1d10..000000000000
--- a/sys-fs/lxcfs/files/lxcfs-fusermount-path.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- /config/init/systemd/lxcfs.service.orig 2018-10-13 17:24:46.534035126 -0500
-+++ /config/init/systemd/lxcfs.service 2018-10-13 17:25:33.007034294 -0500
-@@ -5,10 +5,10 @@
- Documentation=man:lxcfs(1)
-
- [Service]
--ExecStart=/usr/bin/lxcfs /var/lib/lxcfs/
-+ExecStart=/usr/bin/lxcfs -o allow_other,nonempty /var/lib/lxcfs/
- KillMode=process
- Restart=on-failure
--ExecStopPost=-/bin/fusermount -u /var/lib/lxcfs
-+ExecStopPost=-/usr/bin/fusermount -u /var/lib/lxcfs
- Delegate=yes
-
- [Install]
diff --git a/sys-fs/lxcfs/files/lxcfs.initd b/sys-fs/lxcfs/files/lxcfs.initd
deleted file mode 100644
index 5997426fa8e8..000000000000
--- a/sys-fs/lxcfs/files/lxcfs.initd
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-DAEMON=/usr/bin/lxcfs
-PIDFILE=/run/lxcfs.pid
-
-start() {
- ebegin "Starting lxcfs"
-
- start-stop-daemon --start \
- --pidfile ${PIDFILE} \
- --exec ${DAEMON} \
- --background \
- --make-pidfile \
- -- \
- -o allow_other,nonempty /var/lib/lxcfs
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping lxcfs"
- start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
- eend $?
-}
diff --git a/sys-fs/lxcfs/lxcfs-3.0.3.ebuild b/sys-fs/lxcfs/lxcfs-3.0.3.ebuild
deleted file mode 100644
index f9c354a881a3..000000000000
--- a/sys-fs/lxcfs/lxcfs-3.0.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd vcs-snapshot
-DESCRIPTION="FUSE filesystem for LXC"
-HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
- EGIT_BRANCH="master"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/lxc/lxcfs/archive/${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-# Omit all dbus. Upstream appears to require it because systemd, but
-# lxcfs makes no direct use of dbus.
-RDEPEND="
- dev-libs/glib:2
- sys-fs/fuse:0
-"
-DEPEND="
- sys-apps/help2man
- ${RDEPEND}
-"
-PATCHES="${FILESDIR}/${PN}-fusermount-path.patch"
-
-src_prepare() {
- default
- ./bootstrap.sh || die "Failed to bootstrap configure files"
-}
-
-src_configure() {
- # Without the localstatedir the filesystem isn't mounted correctly
- econf --localstatedir=/var
-}
-
-# Test suite fails for me
-# src_test() {
-# emake tests
-# tests/main.sh || die "Tests failed"
-# }
-
-src_install() {
- default
- keepdir /var/lib/lxcfs
- newinitd "${FILESDIR}"/${PN}.initd lxcfs
- systemd_dounit config/init/systemd/lxcfs.service
-}
-
-pkg_preinst() {
- # In an upgrade situation merging /var/lib/lxcfs (an empty dir)
- # fails because that is a live mountpoint when the service is
- # running. It's unnecessary anyway so skip the action.
- [[ -d ${ROOT}/var/lib/lxcfs ]] && rm -rf ${D}/var
-}
-
-pkg_postinst() {
- einfo
- einfo "Starting with version 3.0.0 the cgfs PAM module has moved, and"
- einfo "will eventually be available in app-emulation/lxc. See:"
- einfo "https://brauner.github.io/2018/02/28/lxc-includes-cgroup-pam-module.html"
- einfo "for more information."
- einfo
-}