summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-06 09:58:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-06 09:58:16 +0200
commitf5badf43791499d9526ed5a415c8f259ba2626bb (patch)
tree0982484db6e710dbad4b1fde9d77e26f624c1fa6 /sys-devel
parentsys-libs/libomp: Bump to 15.0.0 (diff)
downloadgentoo-f5badf43791499d9526ed5a415c8f259ba2626bb.tar.gz
gentoo-f5badf43791499d9526ed5a415c8f259ba2626bb.tar.bz2
gentoo-f5badf43791499d9526ed5a415c8f259ba2626bb.zip
sys-devel/clang-runtime: Bump to 15.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"