summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-29 21:59:46 +0000
committerSam James <sam@gentoo.org>2024-11-29 21:59:46 +0000
commit7c053ac40241806d3cdb2e367368c8b66cda447e (patch)
treeee24dce787a1cfec361904a8a236ed292487907c /sys-devel
parentdev-libs/ivykis: Stabilize 0.43.1 ppc, #945365 (diff)
downloadgentoo-7c053ac40241806d3cdb2e367368c8b66cda447e.tar.gz
gentoo-7c053ac40241806d3cdb2e367368c8b66cda447e.tar.bz2
gentoo-7c053ac40241806d3cdb2e367368c8b66cda447e.zip
sys-devel/nvptx-tools: add 0_pre20240809
Bug: https://bugs.gentoo.org/945296 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/nvptx-tools/Manifest1
-rw-r--r--sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/nvptx-tools/Manifest b/sys-devel/nvptx-tools/Manifest
index 59a28d80175c..f8dce9415e1a 100644
--- a/sys-devel/nvptx-tools/Manifest
+++ b/sys-devel/nvptx-tools/Manifest
@@ -1 +1,2 @@
DIST nvptx-tools-0_pre20230122.tar.gz 789116 BLAKE2B f05b922827c0215a2484c4f91f3424ca866bb91435a3d60559fc9f1f63c06559377f1c8071c9e8e5607ec4dbff1c22d095385ac86d35f43ade29d9df6699f3ff SHA512 9d3bceef2ef7942ea6ec8b6c6b1b9144f0a020bfabc2583ba4ef73db8ef299ffadbc6dbe27748c728bd16aee0ecd6f0fbe1f8bb064bde986bb4e0475b2494870
+DIST nvptx-tools-0_pre20240809.tar.gz 994915 BLAKE2B eef94a55d4ec48fb3031e20d5722e4f0564e7ed5ddc217a0b88d15236d9c15bbd60d14ab537e3535c40e800d75578c21833c6f414bdf11f0fed6f7eb3721478a SHA512 b98ee6f045ec820d056ce7cf4af4d3dcabdd0e77d15f02a88dd3e7f60de6ec32ecb454787f1ef626e358cde7744c5635f8d2e8ff78b46a714f627a37ac256ddb
diff --git a/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild b/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild
new file mode 100644
index 000000000000..e76b4259f828
--- /dev/null
+++ b/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of tools for use with nvptx-none GCC toolchains"
+HOMEPAGE="https://github.com/SourceryTools/nvptx-tools https://gcc.gnu.org/wiki/nvptx"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/SourceryTools/nvptx-tools"
+ inherit git-r3
+else
+ MY_COMMIT="a0c1fff6534a4df9fb17937c3c4a4b1071212029"
+ SRC_URI="https://github.com/SourceryTools/nvptx-tools/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+BDEPEND="
+ test? (
+ dev-python/lit
+ dev-util/dejagnu
+ )
+"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|nvptx-*) ;;
+ *) die "Use sys-devel/crossdev to build a nvptx(-none) toolchain" ;;
+ esac
+ fi
+}