summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-06 01:59:55 +0000
committerSam James <sam@gentoo.org>2025-01-06 01:59:55 +0000
commit2a7e458463a0bdaa179f1405048984b5198c79f9 (patch)
tree523ae9f7cd43a6e98d89151c0e1677c655731c92 /sys-devel
parentnet-vpn/i2pd: version bump 2.55.0 (diff)
downloadgentoo-2a7e458463a0bdaa179f1405048984b5198c79f9.tar.gz
gentoo-2a7e458463a0bdaa179f1405048984b5198c79f9.tar.bz2
gentoo-2a7e458463a0bdaa179f1405048984b5198c79f9.zip
sys-devel/crossdev: add 20250106
Sam James (26): crossdev, Makefile: fix version handling again Revert "crossdev, Makefile: fix version handling again" crossdev: nvptx: force on openmp & fortran Revert "crossdev: nvptx: force on openmp & fortran" crossdev: nvptx: add comment wrt GFORCE and openmp/fortran crossdev: drop 'nocxx' (noop) crossdev: small style tweaks crossdev: crank copyright crossdev: build C++ by default for *-newlib/*-elf/*-avr etc ci: fix whitespace ci: add embedded/special targets (arm-none-eabi, nvptx-none) ci: add avr too ci: fix loong and uncomment ci: fix comment typo ci: add HPPA targets ci: don't run loong musl ci: no userland for hppa64 ci: add bpf-unknown-none ci: add s390-ibm-linux-gnu ci: adjust s390x tuple name ci: add alpha-unknown-linux-gnu ci: add powerpc64le-unknown-linux-gnu ci: add more arm targets ci: add aarch64_be-unknown-linux-gnu ci: try to get binpkgs for dev-vcs/git and friends (via eselect-repository) crossdev: special-case bpf Closes: https://bugs.gentoo.org/900713 Closes: https://bugs.gentoo.org/939677 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20250106.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index e975ab1e55a7..359fd20db6dc 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,3 +1,4 @@
DIST crossdev-20240921.tar.xz 31008 BLAKE2B 9daeabcbeefa32624d71b86c5ddeb1f6bf6ccdf4e6f590bf7517388d4d68b73ae2651ca09d122f128f002568127bd5d7d767db9d6c043e5330b62c3104929848 SHA512 6b7f0bce309d2b0a8fdf9b28cf72098de9dafaf7f338a8308e94e2068cefc15cd2407eee39a9eeb0ea0a1bc46569cedc69a51bb01f140faebe374b660cb1cdf6
DIST crossdev-20241202.tar.xz 33032 BLAKE2B 74ec859e1ae5f816397349c18f8bd98d8fae2f4de471112d70621767733a6c91dfffaabb33afc4bdabf5bed31b83a0cdf8afaffaba3e0df95f70d43cf249fb94 SHA512 c6a8c534135aa15b2005546d3f006953570de1e54ae3d3170c71bed62f044c2db79412ecde3b91fd85fca92e7c996762ba086db29c6132f6f1d9e9a48f1e79ea
DIST crossdev-20241215.tar.xz 33028 BLAKE2B 3b33284f55fe41a45bfeea1dbc273a828eeceada38d4274f9fcaab06a1d9b342efaa0fcad407bb5a5d921515acc18dac0e4923240e2610a425f7c508b6274ecd SHA512 84960b518767aacc7400cfa32d36b15492dd5e3908c36c0f513470fdfbaedde04d24aecaf0f5020bf69cd7c2095da1cc2961ae090e90340a176292299bbfaf25
+DIST crossdev-20250106.tar.xz 33124 BLAKE2B 45992cd29a6dd48f97d871ba5f4b09b18797c76389a5839c7b02e23b765556561f9b442d594a6bed58ff670e69d4efc27f37cdb1f6bb1722fd1d18e0bc50cc5f SHA512 8d9cdb194f3477dcbe605c4f8126be013e9193acb716e2b12e8f51f826087bbac3f50b44268c150d4e9f86b78182a0b4b323634b0040f0a815dc4a075c662c75
diff --git a/sys-devel/crossdev/crossdev-20250106.ebuild b/sys-devel/crossdev/crossdev-20250106.ebuild
new file mode 100644
index 000000000000..8c7f0315b59a
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20250106.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}