summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-29 22:56:04 +0100
committerSam James <sam@gentoo.org>2022-09-29 22:56:04 +0100
commit7ed1ea9aeecc4f17ceb35fde1ab62d2aabcbe9cd (patch)
treee8fede0ae10bf2b9e64fd0ca44ed109023694cc1 /sys-devel/gdb
parentsys-devel/binutils: drop unused eclass (elisp-common) (diff)
downloadgentoo-7ed1ea9aeecc4f17ceb35fde1ab62d2aabcbe9cd.tar.gz
gentoo-7ed1ea9aeecc4f17ceb35fde1ab62d2aabcbe9cd.tar.bz2
gentoo-7ed1ea9aeecc4f17ceb35fde1ab62d2aabcbe9cd.zip
sys-devel/gdb: add zstd support to live
See https://maskray.me/blog/2022-09-09-zstd-compressed-debug-sections. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9a3b277f6524..6bf40e5071f6 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -50,7 +50,7 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
+IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# In fact, gdb's test suite needs some work to get passing.
@@ -77,12 +77,9 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
guile? ( >=dev-scheme/guile-2.0 )
xml? ( dev-libs/expat )
- source-highlight? (
- dev-util/source-highlight
- )
- xxhash? (
- dev-libs/xxhash
- )
+ source-highlight? ( dev-util/source-highlight )
+ xxhash? ( dev-libs/xxhash )
+ zstd? ( app-arch/zstd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -204,6 +201,7 @@ src_configure() {
$(use_with python python "${EPYTHON}")
$(use_with xxhash)
$(use_with guile)
+ $(use_with zstd)
)
if use sparc-solaris || use x86-solaris ; then