summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-09-09 20:50:09 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-09-09 21:08:24 +0300
commitf18c709e191b6725d43f4f386b5cb19e7d4f7c21 (patch)
treebab33747fd9e63c8fb6d0a49a8609e99ff851435 /sys-boot
parentdev-db/sqlmap: Stabilize 1.8.7 x86, #939380 (diff)
downloadgentoo-f18c709e191b6725d43f4f386b5cb19e7d4f7c21.tar.gz
gentoo-f18c709e191b6725d43f4f386b5cb19e7d4f7c21.tar.bz2
gentoo-f18c709e191b6725d43f4f386b5cb19e7d4f7c21.zip
sys-boot/gnu-efi: fix building on arm
Broken when trying to implement a workaround for bug #931792. Checking if objcopy supports PE fails on arm. Closes: https://bugs.gentoo.org/939338 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild (renamed from sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild
index 7185e2dbb78c..d492de252a80 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild
@@ -42,7 +42,12 @@ check_and_set_objcopy() {
# llvm-objcopy does not support EFI target, try to use binutils objcopy or fail
tc-export OBJCOPY
OBJCOPY="${OBJCOPY/llvm-/}"
- LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
+ if ! use arm && ! use riscv; then
+ # bug #939338
+ # objcopy does not understand PE/COFF on these arches: arm32, riscv64 and mips64le
+ # gnu-efi containes a workaround
+ LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
+ fi
fi
}