summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-06-15 18:59:36 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-06-15 19:01:34 -0700
commitcebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40 (patch)
tree577fddaa0ec36cabdf762beed423c0f06784e197 /sys-block/sas2ircu/sas2ircu-20.ebuild
parentdev-texlive/texlive-langkorean: Stabilize 2023_p54074-r1 ppc64, #934299 (diff)
downloadgentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.tar.gz
gentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.tar.bz2
gentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.zip
sys-block/sas2ircu: EAPI=8 fixes
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/335749
Diffstat (limited to 'sys-block/sas2ircu/sas2ircu-20.ebuild')
-rw-r--r--sys-block/sas2ircu/sas2ircu-20.ebuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/sys-block/sas2ircu/sas2ircu-20.ebuild b/sys-block/sas2ircu/sas2ircu-20.ebuild
deleted file mode 100644
index 6113f2cb5019..000000000000
--- a/sys-block/sas2ircu/sas2ircu-20.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit mount-boot
-
-DESCRIPTION="LSI MPT-SAS2 controller management tool"
-HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9207-8e#tab-archive-drivers4-abc"
-
-LICENSE="LSI"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~ppc64 ~x86 ~x64-solaris"
-IUSE="uefi doc"
-RESTRICT="strip fetch mirror"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
-
-MY_PN=SAS2IRCU
-MY_P="${MY_PN}_P${PV}"
-
-DISTFILE_BIN=${MY_P}.zip
-DISTFILE_DOC=SAS2_IR_User_Guide.pdf
-DOC_PV=12
-
-SRC_URI="
-https://docs.broadcom.com/docs/${DISTFILE_BIN}
-https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_6g_p20_point6/$DISTFILE_BIN
-doc? ( https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/SAS2_IR_User_Guide.pdf )
-"
-
-LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_nofetch() {
- elog "LSI has a mandatory click-through license on thier binaries."
- elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Management Software and Tools section."
- elog "If the file has been moved again, the license form might be available at https://docs.broadcom.com/docs/${DISTFILE_BIN}"
- elog "After downloading, move ${DISTFILE_BIN} into your DISTDIR directory"
- if use doc; then
- elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
- elog "and also place it into your DISTDIR directory"
- fi
-}
-
-supportedcards() {
- elog "This binary supports should support ALL cards, including, but not"
- elog "limited to the following series:"
- elog ""
- elog "LSI SAS 2004"
- elog "LSI SAS 2008"
- elog "LSI SAS 2108"
- elog "LSI SAS 2208"
- elog "LSI SAS 2304"
- elog "LSI SAS 2308"
- elog "Dell PERC H200, H700"
- elog "IBM System x3200 M2 (4367, 4368)"
- elog "IBM System x3200 M3 (7327, 7328)"
- elog "IBM System x3250 M2 (4190, 4191, 4194)"
- elog "IBM System x3250 M3 (4251, 4252, 4261)"
- elog "IBM System x3350 (4192, 4193)"
- elog "IBM System x3400 (7973, 7974, 7975, 7976)"
- elog "IBM System x3400 M2 (7836, 7837)"
- elog "IBM System x3455 (7940, 7941)"
- elog "IBM System x3500 (7977)"
- elog "IBM System x3500 M2 (7839)"
- elog "IBM System x3550 (7978, 1913)"
- elog "IBM System x3550 M2 (7946, 4198)"
- elog "IBM System x3650 (7979, 1914)"
- elog "IBM System x3650 M2 (7947, 4199)"
- elog "IBM System x3650 NAS (7979)"
- elog "IBM System x3655 (7985, 7943)"
- elog "IBM System x3755 (8877, 7163)"
- elog "IBM System x3850 M2 (7141, 7144, 7233, 7234)"
- elog "IBM System x3850 X5 (7145, 7146)"
- elog "IBM System x3950 M2 (7141, 7233, 7234)"
- elog "IBM System x3950 X5 (7145)"
-}
-
-src_unpack() {
- unpack ${DISTFILE_BIN}
-}
-
-src_install() {
- exeinto /opt/lsi/
- use amd64 || use x86 && doexe sas2ircu_linux_x86_rel/sas2ircu
- use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
- use x64-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
- if use uefi; then
- exeinto /boot/efi/
- doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
- fi
- dodoc Readme_Release_Notes_SAS2IRCU_Phase_${PV}.00.00.00.txt
- dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
- use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
-}