summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 15:24:43 +0000
committerSam James <sam@gentoo.org>2021-03-30 15:25:00 +0000
commit14d657187f80966a99f84ec3d32955d418aa9a96 (patch)
tree56a64178afa4cfb10b37c541e4a135486f0e86fe /sys-auth
parentdev-games/guichan: EAPI 7, fix slibtool build (diff)
downloadgentoo-14d657187f80966a99f84ec3d32955d418aa9a96.tar.gz
gentoo-14d657187f80966a99f84ec3d32955d418aa9a96.tar.bz2
gentoo-14d657187f80966a99f84ec3d32955d418aa9a96.zip
sys-auth/pam_blue: fix build with slibtool
Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/778407 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild b/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild
index ef057190d039..5b2e6ba48f06 100644
--- a/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild
+++ b/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,21 +8,29 @@ inherit autotools pam
DESCRIPTION="PAM module providing ability to authenticate via a bluetooth compatible device"
HOMEPAGE="http://pam.0xdef.net/"
SRC_URI="http://pam.0xdef.net/source/${P}.tar.bz2"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="sys-libs/pam
- net-wireless/bluez"
+DEPEND="
+ net-wireless/bluez
+ sys-libs/pam
+"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${P}-char-locales.patch #412941
+ "${FILESDIR}"/${P}-bad-log.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-char-locales.patch #412941
- eapply "${FILESDIR}"/${P}-bad-log.patch
+
+ # bug #778407
+ sed -i "s|-rpath='/lib/security'|-rpath /lib/security|" src/Makefile.am || die
+
mv configure.{in,ac} || die
eautoreconf
}