summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-05 22:49:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-05 22:49:19 -0500
commit706cf0917b4998a2320782261a807e3b004b0f5b (patch)
treee8eb4a0d3534f9b1c5061329cb5c9e1fb882ca96 /sys-apps
parentgui-apps/mako: 1.5 stable amd64/arm64/x86 (diff)
downloadgentoo-706cf0917b4998a2320782261a807e3b004b0f5b.tar.gz
gentoo-706cf0917b4998a2320782261a807e3b004b0f5b.tar.bz2
gentoo-706cf0917b4998a2320782261a807e3b004b0f5b.zip
sys-apps/bolt: 0.9.1 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/Manifest1
-rw-r--r--sys-apps/bolt/bolt-0.9.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 41dbe3bd2d07..b9ff8e808f5d 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1 +1,2 @@
+DIST bolt-0.9.1.tar.gz 250978 BLAKE2B a3b1ea51704e2b54abb0135013019b9cad6ed9c0acfdb56797e19c9b5a1abe9f921446cfcc5b664f73bbbff857cf8d420f588517d4c633d1b3776a35c37fc882 SHA512 c925c290de75d3fa2dfb9e86b2f14ea39279b3f2ab6bebeced72a7853c901d44de02157d684534af2b54edd3a2e0b2ba61e889579ab1b192f99e98a2d73685d9
DIST bolt-0.9.tar.gz 238596 BLAKE2B 8032ecb83d39d6c3550c000eed400ee0451e5ed94f7c898ffe9c8fcf512af387cfd759bd94241a47623b5aac63615bcda40ddb3e9ae3ec4060da20e46d7e9b7d SHA512 427e9ad95a8d018dd22326cc4b458fc9149b001d3aa6e4bb8e4047eaf6c3cf04a4dc3be9396049734dc0bd54f990b3bce31b6eef4031e3b671a6202a588cfe78
diff --git a/sys-apps/bolt/bolt-0.9.1.ebuild b/sys-apps/bolt/bolt-0.9.1.ebuild
new file mode 100644
index 000000000000..34cd766665ec
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ check_extra_config
+
+ CONFIG_CHECK="~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+ check_extra_config
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}