summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-02 21:24:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-02 21:24:40 +0100
commit13dea100afcf22cfc9ad063b302c0f293aa0490a (patch)
treef3909fd4c524e96ee836786bf2a7065c1f5c0c2d /sys-apps
parentsys-apps/smartmontools: Synced live ebuild (diff)
downloadgentoo-13dea100afcf22cfc9ad063b302c0f293aa0490a.tar.gz
gentoo-13dea100afcf22cfc9ad063b302c0f293aa0490a.tar.bz2
gentoo-13dea100afcf22cfc9ad063b302c0f293aa0490a.zip
sys-apps/smartmontools: Revbump fixing QA issue
Closes: https://bugs.gentoo.org/695108 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/metadata.xml1
-rw-r--r--sys-apps/smartmontools/smartmontools-7.1-r1.ebuild (renamed from sys-apps/smartmontools/smartmontools-7.1.ebuild)20
2 files changed, 10 insertions, 11 deletions
diff --git a/sys-apps/smartmontools/metadata.xml b/sys-apps/smartmontools/metadata.xml
index 9ac33efa0d52..4ee89aff231c 100644
--- a/sys-apps/smartmontools/metadata.xml
+++ b/sys-apps/smartmontools/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="caps">Build against <pkg>sys-libs/libcap-ng</pkg> to allow smartd to drop its privileges.</flag>
<flag name="daemon">Install the monitoring daemon (smartd) and associated scripts.</flag>
- <flag name="update_drivedb">Install a script to update the drivedb file.</flag>
<flag name="update-drivedb">Install a script to update the drivedb file.</flag>
</use>
<upstream>
diff --git a/sys-apps/smartmontools/smartmontools-7.1.ebuild b/sys-apps/smartmontools/smartmontools-7.1-r1.ebuild
index 0b1811bc1f8c..158bfd6444fc 100644
--- a/sys-apps/smartmontools/smartmontools-7.1.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.smartmontools.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps +daemon selinux static systemd update_drivedb"
+IUSE="caps +daemon selinux static systemd update-drivedb"
DEPEND="
caps? (
@@ -32,7 +32,7 @@ RDEPEND="${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
systemd? ( sys-apps/systemd )
- update_drivedb? (
+ update-drivedb? (
app-crypt/gnupg
|| (
net-misc/curl
@@ -61,8 +61,8 @@ src_configure() {
$(use_with caps libcap-ng)
$(use_with selinux)
$(use_with systemd libsystemd)
- $(use_with update_drivedb gnupg)
- $(use_with update_drivedb update-smart-drivedb)
+ $(use_with update-drivedb gnupg)
+ $(use_with update-drivedb update-smart-drivedb)
$(usex systemd "--with-systemdsystemunitdir=$(systemd_get_systemunitdir)" '')
)
econf "${myeconfargs[@]}"
@@ -84,7 +84,7 @@ src_install() {
einstalldocs
fi
- if use update_drivedb ; then
+ if use update-drivedb ; then
if ! use daemon; then
dosbin "${S}"/update-smart-drivedb
fi
@@ -93,7 +93,7 @@ src_install() {
doexe "${FILESDIR}/${PN}-update-drivedb"
fi
- if use daemon || use update_drivedb; then
+ if use daemon || use update-drivedb; then
keepdir "${db_path}"
# Install a copy of the initial drivedb.h to /usr/share/${PN}
@@ -113,7 +113,7 @@ src_install() {
}
pkg_postinst() {
- if use daemon || use update_drivedb; then
+ if use daemon || use update-drivedb; then
local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
local db_path="${EROOT}/var/db/${PN}"
@@ -137,10 +137,10 @@ pkg_postinst() {
ewarn ""
ewarn " /usr/sbin/update-smart-drivedb"
- if ! use update_drivedb ; then
+ if ! use update-drivedb ; then
ewarn ""
ewarn "However, 'update-smart-drivedb' requires that you re-emerge ${PN}"
- ewarn "with USE='update_drivedb'."
+ ewarn "with USE='update-drivedb'."
fi
fi
fi