summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-22 19:24:42 -0400
committerSam James <sam@gentoo.org>2024-05-23 02:35:34 +0100
commit229b7fbb635b6041750d4fa56a7867abe50214d6 (patch)
treefcad4779eb5052b9927fe86d56649c253073680a /sys-apps/xmbmon
parentsys-block/fio: update EAPI 7 -> 8 (diff)
downloadgentoo-229b7fbb635b6041750d4fa56a7867abe50214d6.tar.gz
gentoo-229b7fbb635b6041750d4fa56a7867abe50214d6.tar.bz2
gentoo-229b7fbb635b6041750d4fa56a7867abe50214d6.zip
sys-apps/xmbmon: regenerate vintage 2002 configure script
It had a Modern C warning because the ancient standard routines failed to detect that STDC_HEADERS could be safely set: ``` checking for ANSI C header files... no ``` Fortunately the code never relied on this anyway, so it was a moot point. But a noisy one. Autoconf 2.53 is pretty long in the tooth so take this opportunity to freshen up, anyway. Closes: https://bugs.gentoo.org/908576 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/xmbmon')
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.5-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/xmbmon/xmbmon-2.0.5-r2.ebuild b/sys-apps/xmbmon/xmbmon-2.0.5-r2.ebuild
index 40e0701452e6..b5bf59a4db20 100644
--- a/sys-apps/xmbmon/xmbmon-2.0.5-r2.ebuild
+++ b/sys-apps/xmbmon/xmbmon-2.0.5-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
MY_P=${PN}${PV//.}
DESCRIPTION="Mother Board Monitor Program for X Window System"
@@ -43,7 +45,9 @@ src_prepare() {
Makefile.in || die
sed -i \
-e '/^[[:space:]]*CC=gcc/s,.*,:;,' \
- configure || die
+ configure.in || die
+
+ eautoreconf
}
src_compile() {