summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-13 16:02:37 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-13 17:20:06 -0400
commit0dd5ccd23ce36502b62a5ff24bc19d43f0ca1f4d (patch)
tree0d8303299ab3a90db447da5c50940b74c4e89822 /sys-apps/xdg-desktop-portal-gnome
parentgnome-extra/gnome-software: Version bump to 44_rc (diff)
downloadgentoo-0dd5ccd23ce36502b62a5ff24bc19d43f0ca1f4d.tar.gz
gentoo-0dd5ccd23ce36502b62a5ff24bc19d43f0ca1f4d.tar.bz2
gentoo-0dd5ccd23ce36502b62a5ff24bc19d43f0ca1f4d.zip
sys-apps/xdg-desktop-portal-gnome: Version bump to 44_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30099 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index d449cf5300d0..e1a2d817b1de 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-gnome-43.1.tar.xz 125248 BLAKE2B 5290041b3b0d24c6d62c1433c492fa5b04af80493d192392d6b89839356c1a4f2c74aba5509476bd5df5383375889d50636216b52e2448de1b3c8360501cb16b SHA512 fc9b2a0bf5483194326308099be0cb76245644bfc26546a4e63679eb695400cf254aa9e85de1b168e07ba7f05eb4f9fe4fde31853bcee4bd8bfb94063933ebc3
+DIST xdg-desktop-portal-gnome-44.rc.tar.xz 127040 BLAKE2B b762d1e29cad9ed9afa98cfd98793a2b27c1553beccdaf6bccceaf642cd35d9d28bcbc3b4be891d1fb54efe99a27d62cf190f317deb26ea837b73b0448272a58 SHA512 bb3be21cbb4cb0e1fb22ae70d4c47cbd8b8bc6e87d4495f967fb4f8494cdcb0f1b3d03c15d12ed9cec4fca31151e99a967b38b3eb46cfdcc791f399185ceeacc
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
new file mode 100644
index 000000000000..dc27622098d4
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.rc.tar.xz"
+S="${WORKDIR}/${PN}-44.rc"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.15.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}