summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-08-14 11:33:10 -0500
committerBen Kohler <bkohler@gentoo.org>2023-08-14 11:34:30 -0500
commit6565b0a84e22c9292dde2a41fab0457d6c3aaafd (patch)
tree543321c40673fab658c6fbf5bbbf172b56f91d6b /sys-apps/pcmciautils
parentsci-libs/safetensors: fix build (diff)
downloadgentoo-6565b0a84e22c9292dde2a41fab0457d6c3aaafd.tar.gz
gentoo-6565b0a84e22c9292dde2a41fab0457d6c3aaafd.tar.bz2
gentoo-6565b0a84e22c9292dde2a41fab0457d6c3aaafd.zip
sys-apps/pcmciautils: add 018_p14
Closes: https://bugs.gentoo.org/725788 Closes: https://bugs.gentoo.org/832880 Closes: https://bugs.gentoo.org/851819 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/pcmciautils')
-rw-r--r--sys-apps/pcmciautils/Manifest1
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p14.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/pcmciautils/Manifest b/sys-apps/pcmciautils/Manifest
index 453c3097e25f..63bc74b18f3d 100644
--- a/sys-apps/pcmciautils/Manifest
+++ b/sys-apps/pcmciautils/Manifest
@@ -1,2 +1,3 @@
+DIST pcmciautils_018-14.debian.tar.xz 11516 BLAKE2B f023fce015a71a09b4b012c0d7396bc8eb426ccbd3c92e0ce7bd46c5f5d2510d0eae5a296300017e316fef1a6471d0040e8f84afc989d7f5fba734fdd5e11e1e SHA512 e5c98cbe54da296a8de05916f2e987f0dd5668e39a65f771e46aa5b1a04aa4821c3c5d0c94b0c9bede26df011f6a441be91f3c49105ceaca631daf013fbd6430
DIST pcmciautils_018-8.debian.tar.gz 11213 BLAKE2B cf28ecf71ebfd5c4ad7d882cbadab71b787f407adb2d20258cdc1157ca7d542bf398ff09207037d1d6e933d43e477b50b28ca3f0ac0e557fbaefb9f31656843e SHA512 8a00d776e208b43d01fe22b9d4e889bc1b2c5982aa1bf225bdd613ffb0f5b37f5266ccc1cb91df9ac49c4ee3e3653ebb29807b61fff53c585e2cfed5aa2cd9e9
DIST pcmciautils_018.orig.tar.gz 48516 BLAKE2B 0b197cdd7d0940e5c0eee2da961f0f4dd972a3178ba5d07a6492185d0ab156cd61f5343c8f9d812cff402f04af76a15baa3db564d14317d3817e5325dd8811fb SHA512 f0af1fc6155686ae61c1c85a6451b032088a3880dfbc05c1d1ed33ca8e975745f9d4bedb0f3ee0a1252461aa008bed8014c73ff850cddd89d930524a6d68d47d
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p14.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p14.ebuild
new file mode 100644
index 000000000000..3d67aacffffa
--- /dev/null
+++ b/sys-apps/pcmciautils/pcmciautils-018_p14.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic linux-info toolchain-funcs udev
+
+DEB_REV=${PV#*_p}
+MY_PV=${PV%_p*}
+
+DESCRIPTION="PCMCIA userspace utilities for Linux"
+HOMEPAGE="https://packages.qa.debian.org/pcmciautils"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.xz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~riscv ~x86"
+IUSE="debug staticsocket"
+
+RDEPEND="sys-apps/kmod[tools]"
+DEPEND="${RDEPEND}
+ app-alternatives/yacc
+ sys-devel/flex"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+ "${FILESDIR}"/${PN}-018_p8-flex-2.6.3-fix.patch
+ "${FILESDIR}"/${PN}-018_p8-musl-unsigned-type.patch
+ "${WORKDIR}"/debian/patches/parallel-build.patch
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~PCMCIA"
+ linux-info_pkg_setup
+
+ kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
+
+ mypcmciaopts=(
+ STARTUP=$(usex staticsocket false true)
+ exec_prefix=/usr
+ UDEV=true
+ DEBUG=false
+ STATIC=false
+ V=true
+ udevdir="$(get_udevdir)"
+ CC="$(tc-getCC)"
+ HOSTCC="$(tc-getBUILD_CC)"
+ LD="$(tc-getCC)"
+ AR="$(tc-getAR)"
+ STRIP=true
+ RANLIB="$(tc-getRANLIB)"
+ OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
+ )
+}
+
+src_compile() {
+ emake "${mypcmciaopts[@]}"
+}
+
+src_install() {
+ emake "${mypcmciaopts[@]}" DESTDIR="${D}" install
+
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}