summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-04 01:35:01 +0100
committerSam James <sam@gentoo.org>2024-07-04 01:35:01 +0100
commit13e6983dc3e5d04da009ab04888d754b1ec0f4f2 (patch)
treeadb7b8af474e344cada8e1c72ccc7979164e4c7e /sys-apps/moar
parentnet-proxy/squid: fix src_unpack w/ USE=verify-sig (diff)
downloadgentoo-13e6983dc3e5d04da009ab04888d754b1ec0f4f2.tar.gz
gentoo-13e6983dc3e5d04da009ab04888d754b1ec0f4f2.tar.bz2
gentoo-13e6983dc3e5d04da009ab04888d754b1ec0f4f2.zip
sys-apps/moar: add 1.24.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.24.6.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index ce260c3c6636..dd67e2ce595b 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -6,3 +6,5 @@ DIST moar-1.24.3-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c
DIST moar-1.24.3.tar.gz 2806023 BLAKE2B 7deb1319bf887e117867f4d2a4ede54a618d787d9bdf2c2a3a69d6da376ad7aaa52f8cd2d66da8d6fecd441902b36bd32a8b623c06af142d18422558fff827ab SHA512 7e109eced995c080df54a7c79d96a0403da1246fbd1a30be5c66479740824e3c34e0a3ac2679a7c27e5d0180c6818ea4322a07b71fa3a724d2778458b750653f
DIST moar-1.24.4-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
DIST moar-1.24.4.tar.gz 2806042 BLAKE2B bbe10b9c829074a572f7b741eb5349d02329decc2bdec85e743e177784530ae349653a6941b994c2a3de6496d5ce39c451480a689ceae9daeba6ab13c9e6f555 SHA512 872e7a537b6383665b8f2af0ba92973dca3fa7c1c240db1be34b97cb38274e7aeb81281371809972004f08424bdd78d6c32bc39db2a4ecf22545c5c5ab38ee7b
+DIST moar-1.24.6-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.24.6.tar.gz 2806800 BLAKE2B c412c62f7a1c9dba73e1ae7b31d43ffa58789e93a22b357dc4469168fd5cef95732a2363fadb4b4266169de5aaf3e541c4212730425e4c2ad91f194c7e9107f7 SHA512 77d5b789449806e8355702af762cd4cd604a885e7ffdebfcd6601073ea8cd0893c12999662352780d9915a9fbcb3bbc35e1e5b637e1ae15f73a5e65ca632193e
diff --git a/sys-apps/moar/moar-1.24.6.ebuild b/sys-apps/moar/moar-1.24.6.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.24.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}