summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-23 03:35:23 +0100
committerSam James <sam@gentoo.org>2024-06-23 03:35:23 +0100
commit0bb5f55e4405ce874347c9790b91d72b230dd3a7 (patch)
treec6642483f583c19a38acc285fee7bc7f07e93ea1 /sys-apps/moar
parentsys-process/unixtop: EAPI 8 (diff)
downloadgentoo-0bb5f55e4405ce874347c9790b91d72b230dd3a7.tar.gz
gentoo-0bb5f55e4405ce874347c9790b91d72b230dd3a7.tar.bz2
gentoo-0bb5f55e4405ce874347c9790b91d72b230dd3a7.zip
sys-apps/moar: add 1.24.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.24.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 2092c4a67698..5c8c92f96de2 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -6,3 +6,5 @@ DIST moar-1.23.15-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2
DIST moar-1.23.15.tar.gz 2804019 BLAKE2B b870275909af4b16f20f755186bcc834045854e4612780e5ec7fd64f352699da1a704918e5a3e0b1544c4363ace32f789f3a714a977f69acfda83b0f36d7ebe8 SHA512 cb2aded40af9f80199dc84008552c9eda989d2de90f00ce2b37b7cdd3c16a387fe5a78593bde71b62bfe0d02e2b2dc051f91159ccd2466570847a6e2c1b5445c
DIST moar-1.23.9-deps.tar.xz 37188500 BLAKE2B a5c92f8e56d4c7588265132f33089f1086fb7a14b1d1023caf7594cbda16772776751a80d44f451a9c5c765bd03d25687a63b5a00c4a50603b4598162920d840 SHA512 44c924339dbde95b647c464a00382786dfd8adfc72f307a9df63ed39f85fefe76260fde082a39738fb97c571217e8d591bdeada054dbe75ed56aa0156e7cf2fa
DIST moar-1.23.9.tar.gz 2804191 BLAKE2B d5663fedd70fc80d70a206c276ece6ec11da4f4b4dc396a3e11b1fb8edd5bd9f3395e943158c4bb297b5ebfeecd8f61bdbaaff79e78c4a89458f1b1a02db0e71 SHA512 9ab4a3e49b66b39f642b6a1f882c0980a4e755e3e127ca37d1319615ae836fe3250676a8c0e95ccd0f8e714357df5dc00235bf67be6097a7b2811f0e3bf02e9f
+DIST moar-1.24.0-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.24.0.tar.gz 2805681 BLAKE2B 02ec37082a65df2d9b2bc7b0149384f005e8b9bfe89b5ff198e376d3ae235089e858ca8866c9fd4e8f36e254915aa0ac6b17ebdb31521cf207784eb33025c2c6 SHA512 6351a4505b693f9b6dfdcd495a9f1da3fa717870d3ba2e77b65d19296a9c3b9fce53f518aea402acb9a78423cb7cb40bc5c6ed72be1115b46c1002a5cfa1dfab
diff --git a/sys-apps/moar/moar-1.24.0.ebuild b/sys-apps/moar/moar-1.24.0.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.24.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}