summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2022-12-28 21:38:09 +0100
committerSam James <sam@gentoo.org>2022-12-28 21:00:03 +0000
commitd2518948601d7f71c6b2a151e7269b6c272384f9 (patch)
tree1c62fc4e4aca71805415d778bc497a8d947d7534 /sys-apps/hponcfg
parentsys-apps/hponcfg: drop 4.6.0.0, 5.4.0.0 (diff)
downloadgentoo-d2518948601d7f71c6b2a151e7269b6c272384f9.tar.gz
gentoo-d2518948601d7f71c6b2a151e7269b6c272384f9.tar.bz2
gentoo-d2518948601d7f71c6b2a151e7269b6c272384f9.zip
sys-apps/hponcfg: update EAPI 7 -> 8
Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/28878 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hponcfg')
-rw-r--r--sys-apps/hponcfg/hponcfg-5.6.0.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/hponcfg/hponcfg-5.6.0.0-r1.ebuild b/sys-apps/hponcfg/hponcfg-5.6.0.0-r1.ebuild
new file mode 100644
index 000000000000..d0ac235482e9
--- /dev/null
+++ b/sys-apps/hponcfg/hponcfg-5.6.0.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pax-utils rpm
+
+MY_PV=$(ver_rs 3 '-')
+
+DESCRIPTION="HP Lights-Out Online Configuration Utility (HPONCFG)"
+HOMEPAGE="https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-a00007610en_us"
+SRC_URI="https://downloads.linux.hpe.com/SDR/repo/spp/RHEL/7/x86_64/current/${PN}-${MY_PV}.x86_64.rpm"
+
+LICENSE="hpe"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="elibc_glibc? ( >sys-libs/glibc-2.14 )"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="usr/sbin/hponcfg usr/lib*/libcp*"
+QA_PREBUILT="${QA_PRESTRIPPED}"
+
+src_install() {
+ dosbin sbin/hponcfg
+
+ # When bumping, verify SONAME (scanelf -S libhponcfg64.so)!
+ newlib.so "${S}"/usr/lib64/libhponcfg64.so libcpqci64.so.3
+ dosym libcpqci64.so.3 /usr/$(get_libdir)/libhponcfg64.so
+
+ dodoc "${S}"/usr/share/doc/hponcfg/*
+
+ pax-mark m "${D}"/usr/sbin/hponcfg
+}