summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dtc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dtc')
-rw-r--r--sys-apps/dtc/Manifest3
-rw-r--r--sys-apps/dtc/dtc-1.3.0-r1.ebuild52
-rw-r--r--sys-apps/dtc/dtc-1.3.0.ebuild46
-rw-r--r--sys-apps/dtc/dtc-1.4.0.ebuild52
-rw-r--r--sys-apps/dtc/dtc-1.4.1-r1.ebuild52
-rw-r--r--sys-apps/dtc/dtc-1.4.1.ebuild49
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild49
-rw-r--r--sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch118
-rw-r--r--sys-apps/dtc/files/dtc-1.4.1-echo-n.patch95
-rw-r--r--sys-apps/dtc/files/dtc-1.4.1-missing-syms.patch30
-rw-r--r--sys-apps/dtc/metadata.xml8
11 files changed, 554 insertions, 0 deletions
diff --git a/sys-apps/dtc/Manifest b/sys-apps/dtc/Manifest
new file mode 100644
index 000000000000..7fc19d27d520
--- /dev/null
+++ b/sys-apps/dtc/Manifest
@@ -0,0 +1,3 @@
+DIST dtc-1.4.1.tar.xz 107920 SHA256 77992ad8eac7b68f553d0ba58e5b51604ac803d126196c99e3ae38aaae28bb94 SHA512 63df730e65f62b8c9648cfee5461809188f4198cbf98de25fbe5cb7f2f43c405266abb740501740f59847dc6faf0588bcbc734d08ae5430b05c2601e070d6d05 WHIRLPOOL 93e9ed26024e4650bb2de6323ea639a3e52622aa3891a9f9404959b600d2c1cbc633d18e30d3629ac54ae662e8c58a7d0ca7910a9b323cd8dd4ff6e43a3fdf67
+DIST dtc-v1.3.0.tgz 108540 SHA256 4da48956d812e221f68d1d538cd58ca8ed7412af4ab9ef42a702db9173c372fe SHA512 4506eb4c3eaccabbf6773a3b0cbf3b174560e5004cf8af9f88448ad1371d1c57d793f078b2bd99b63714df538e74d6dfe16f112bc8283d412b1026f5f5c8220e WHIRLPOOL 4e87da05024d94998999a5e0090f91e4af4a66937dc6d5deec9bf7dd320fd9e732d30ccb6195dd0ce924c0f3c817d6af4731761e08dbc0e365e85ad8719e7935
+DIST dtc-v1.4.0.tar.xz 105160 SHA256 6df33a5da65fd43e0bc265a6c99104ca2962a97cf2d78171ed10d68e546ce198 SHA512 d0021c27e3614776db72c3d84cf05b98b1c49e14991ce12db6a90e9ac7d8aa248064f071c7a3b5bc9a20e9b22f070187778faa49bb3a5d0916afdfd9a929b743 WHIRLPOOL 366dd030aeaf042a7b60c7f900befaac124799d2db02c272d513615e08b208de26ab678c2dc48187f52f19bc2d5bcdf9b5694521298122706726e11ddaaa2afe
diff --git a/sys-apps/dtc/dtc-1.3.0-r1.ebuild b/sys-apps/dtc/dtc-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..02bacac2b7cd
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.3.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+MY_P="${PN}-v${PV}"
+
+inherit multilib toolchain-funcs eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.jdl.com/software/dtc.git"
+ inherit git-2
+else
+ SRC_URI="http://www.jdl.com/software/${MY_P}.tgz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Open Firmware device-trees compiler"
+HOMEPAGE="http://git.jdl.com/gitweb/?p=dtc.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fdtdump.patch #372895
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e '/^PREFIX =/s:=.*:= /usr:' \
+ -e "/^LIBDIR =/s:=.*:= /usr/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-1.3.0.ebuild b/sys-apps/dtc/dtc-1.3.0.ebuild
new file mode 100644
index 000000000000..3ea96bc5d330
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Open Firmware device-trees compiler"
+HOMEPAGE="http://www.t2-project.org/packages/dtc.html"
+SRC_URI="http://www.jdl.com/software/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:CFLAGS =:CFLAGS +=:" \
+ -e "s:CPPFLAGS =:CPPFLAGS +=:" \
+ -e "s:-Werror::" \
+ -e "s:-g -Os::" \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export AR CC
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)"
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" \
+ install
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-1.4.0.ebuild b/sys-apps/dtc/dtc-1.4.0.ebuild
new file mode 100644
index 000000000000..af5971fa62e2
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+MY_P="${PN}-v${PV}"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.jdl.com/software/dtc.git"
+ inherit git-2
+else
+ SRC_URI="http://www.jdl.com/software/${MY_P}.tar.xz"
+ KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+fi
+
+DESCRIPTION="Open Firmware device-trees compiler"
+HOMEPAGE="http://git.jdl.com/gitweb/?p=dtc.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils
+ sys-devel/flex
+ sys-devel/bison"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e '/^PREFIX =/s:=.*:= /usr:' \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-1.4.1-r1.ebuild b/sys-apps/dtc/dtc-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..a4f80e253c20
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.4.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Open Firmware device tree compiler"
+HOMEPAGE="http://devicetree.org/Device_Tree_Compiler"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-missing-syms.patch
+ epatch "${FILESDIR}"/${P}-echo-n.patch
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ # Enable parallel tests.
+ emake check
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-1.4.1.ebuild b/sys-apps/dtc/dtc-1.4.1.ebuild
new file mode 100644
index 000000000000..97f68422844b
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+fi
+
+DESCRIPTION="Open Firmware device tree compiler"
+HOMEPAGE="http://devicetree.org/Device_Tree_Compiler"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
new file mode 100644
index 000000000000..7550c05bc8b8
--- /dev/null
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Open Firmware device tree compiler"
+HOMEPAGE="http://devicetree.org/Device_Tree_Compiler"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}
diff --git a/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch b/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch
new file mode 100644
index 000000000000..0bb1c8c88742
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.3.0-fdtdump.patch
@@ -0,0 +1,118 @@
+https://bugs.gentoo.org/372895
+
+From 8f459c5d72673e1a3a119ac58a7eee56236fca73 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 25 Oct 2011 17:29:24 -0400
+Subject: [PATCH] fdtdump: rename from ftdump
+
+The freetype package already installs a binary named "ftdump", so the dtc
+package conflicts with that. So rename the newer dtc tool to "fdtdump".
+This even makes a bit more sense:
+ ftdump: [F]lat device [T]ree [dump]
+ fdtdump: [F]lat [D]evice [T]ree [dump]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Acked-by: David Gibson <david@gibson.dropbear.id.au>
+---
+ .gitignore | 2 +-
+ Documentation/manual.txt | 10 +++++-----
+ Makefile | 6 +++---
+ Makefile.utils | 6 +++---
+ ftdump.c => fdtdump.c | 2 +-
+ 5 files changed, 13 insertions(+), 13 deletions(-)
+ rename ftdump.c => fdtdump.c (97%)
+
+diff --git a/Documentation/manual.txt b/Documentation/manual.txt
+index f8a8a7b..14508f3 100644
+--- a/Documentation/manual.txt
++++ b/Documentation/manual.txt
+@@ -21,7 +21,7 @@ III - libfdt
+
+ IV - Utility Tools
+ 1) convert-dtsv0 -- Conversion to Version 1
+- 1) ftdump
++ 1) fdtdump
+
+
+ I - "dtc", the device tree compiler
+@@ -643,10 +643,10 @@ a new file with a "v1" appended the filename.
+ Comments, empty lines, etc. are preserved.
+
+
+-2) ftdump -- Flat Tree dumping utility
++2) fdtdump -- Flat Device Tree dumping utility
+
+-The ftdump program prints a readable version of a flat device tree file.
++The fdtdump program prints a readable version of a flat device tree file.
+
+-The syntax of the ftdump command line is:
++The syntax of the fdtdump command line is:
+
+- ftdump <DTB-file-name>
++ fdtdump <DTB-file-name>
+diff --git a/Makefile b/Makefile
+index b32409b..4582f5d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,7 +109,7 @@ include Makefile.utils
+
+ BIN += convert-dtsv0
+ BIN += dtc
+-BIN += ftdump
++BIN += fdtdump
+
+ SCRIPTS = dtdiff
+
+@@ -119,7 +119,7 @@ all: $(BIN) libfdt
+ ifneq ($(DEPTARGETS),)
+ -include $(DTC_OBJS:%.o=%.d)
+ -include $(CONVERT_OBJS:%.o=%.d)
+--include $(FTDUMP_OBJS:%.o=%.d)
++-include $(FDTDUMP_OBJS:%.o=%.d)
+ endif
+
+
+@@ -178,7 +178,7 @@ convert-dtsv0: $(CONVERT_OBJS)
+ @$(VECHO) LD $@
+ $(LINK.c) -o $@ $^
+
+-ftdump: $(FTDUMP_OBJS)
++fdtdump: $(FDTDUMP_OBJS)
+
+
+ #
+diff --git a/Makefile.utils b/Makefile.utils
+index 0ed9297..fae5b00 100644
+--- a/Makefile.ftdump
++++ b/Makefile.ftdump
+@@ -4,8 +4,8 @@
+ # into other systems of Makefiles.
+ #
+
+-FTDUMP_SRCS = \
+- ftdump.c
++FDTDUMP_SRCS = \
++ fdtdump.c
+
+-FTDUMP_GEN_SRCS =
++FDTDUMP_GEN_SRCS =
+
+-FTDUMP_OBJS = $(FTDUMP_SRCS:%.c=%.o) $(FTDUMP_GEN_SRCS:%.c=%.o)
++FDTDUMP_OBJS = $(FDTDUMP_SRCS:%.c=%.o) $(FDTDUMP_GEN_SRCS:%.c=%.o)
+diff --git a/ftdump.c b/fdtdump.c
+similarity index 97%
+rename from ftdump.c
+rename to fdtdump.c
+index cc55fe2..207a46d 100644
+--- a/ftdump.c
++++ b/fdtdump.c
+@@ -1,5 +1,5 @@
+ /*
+- * ftdump.c - Contributed by Pantelis Antoniou <pantelis.antoniou AT gmail.com>
++ * fdtdump.c - Contributed by Pantelis Antoniou <pantelis.antoniou AT gmail.com>
+ */
+
+ #include <stdint.h>
+--
+1.7.12.4
+
diff --git a/sys-apps/dtc/files/dtc-1.4.1-echo-n.patch b/sys-apps/dtc/files/dtc-1.4.1-echo-n.patch
new file mode 100644
index 000000000000..cd45b952a49e
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.4.1-echo-n.patch
@@ -0,0 +1,95 @@
+From ed3d76cd1c8f91f5e86424e899448d6221b0f76c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Wed, 6 May 2015 01:53:39 -0400
+Subject: [PATCH] tests: convert `echo -n` to `printf`
+
+The -n option is not standard in POSIX, so convert to printf which should
+work the same in every shell.
+
+Signed-off-by: Mike Frysinger <vapier@chromium.org>
+---
+ tests/run_tests.sh | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/tests/run_tests.sh b/tests/run_tests.sh
+index c870432..0dda54a 100755
+--- a/tests/run_tests.sh
++++ b/tests/run_tests.sh
+@@ -42,20 +42,20 @@ base_run_test() {
+
+ shorten_echo () {
+ limit=32
+- echo -n "$1"
++ printf "$1"
+ shift
+ for x; do
+ if [ ${#x} -le $limit ]; then
+- echo -n " $x"
++ printf " $x"
+ else
+ short=$(echo "$x" | head -c$limit)
+- echo -n " \"$short\"...<${#x} bytes>"
++ printf " \"$short\"...<${#x} bytes>"
+ fi
+ done
+ }
+
+ run_test () {
+- echo -n "$@: "
++ printf "$@: "
+ if [ -n "$VALGRIND" -a -f $1.supp ]; then
+ VGSUPP="--suppressions=$1.supp"
+ fi
+@@ -63,7 +63,7 @@ run_test () {
+ }
+
+ run_sh_test () {
+- echo -n "$@: "
++ printf "$@: "
+ base_run_test sh "$@"
+ }
+
+@@ -106,12 +106,12 @@ wrap_error () {
+
+ run_wrap_error_test () {
+ shorten_echo "$@"
+- echo -n " {!= 0}: "
++ printf " {!= 0}: "
+ base_run_test wrap_error "$@"
+ }
+
+ run_dtc_test () {
+- echo -n "dtc $@: "
++ printf "dtc $@: "
+ base_run_test wrap_test $VALGRIND $DTC "$@"
+ }
+
+@@ -126,7 +126,7 @@ asm_to_so_test () {
+ run_fdtget_test () {
+ expect="$1"
+ shift
+- echo -n "fdtget-runtest.sh "$expect" $@: "
++ printf "fdtget-runtest.sh "$expect" $@: "
+ base_run_test sh fdtget-runtest.sh "$expect" "$@"
+ }
+
+@@ -134,14 +134,14 @@ run_fdtput_test () {
+ expect="$1"
+ shift
+ shorten_echo fdtput-runtest.sh "$expect" "$@"
+- echo -n ": "
++ printf ": "
+ base_run_test sh fdtput-runtest.sh "$expect" "$@"
+ }
+
+ run_fdtdump_test() {
+ file="$1"
+ shorten_echo fdtdump-runtest.sh "$file"
+- echo -n ": "
++ printf ": "
+ base_run_test sh fdtdump-runtest.sh "$file"
+ }
+
+--
+2.4.0
+
diff --git a/sys-apps/dtc/files/dtc-1.4.1-missing-syms.patch b/sys-apps/dtc/files/dtc-1.4.1-missing-syms.patch
new file mode 100644
index 000000000000..7057be7bd8ac
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.4.1-missing-syms.patch
@@ -0,0 +1,30 @@
+From a4b093f7366fdb429ca1781144d3985fa50d0fbb Mon Sep 17 00:00:00 2001
+From: Julien Grall <julien.grall@linaro.org>
+Date: Tue, 17 Mar 2015 16:00:34 +0000
+Subject: [PATCH] libfdt: Add missing functions to shared library
+
+The commit 4e76ec7 "libfdt: Add fdt_next_subnode() to permit easy
+subnode iteration" adds new functions (fdt_{first,next}_subnode) but
+forgot to mark them as 'global' in the shared library.
+
+Signed-off-by: Julien Grall <julien.grall@linaro.org>
+---
+ libfdt/version.lds | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/libfdt/version.lds b/libfdt/version.lds
+index 80b322b..941208e 100644
+--- a/libfdt/version.lds
++++ b/libfdt/version.lds
+@@ -54,6 +54,8 @@ LIBFDT_1.2 {
+ fdt_get_property_by_offset;
+ fdt_getprop_by_offset;
+ fdt_next_property_offset;
++ fdt_first_subnode;
++ fdt_next_subnode;
+
+ local:
+ *;
+--
+2.4.0
+
diff --git a/sys-apps/dtc/metadata.xml b/sys-apps/dtc/metadata.xml
new file mode 100644
index 000000000000..ccba990cce68
--- /dev/null
+++ b/sys-apps/dtc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc64</herd>
+<maintainer>
+ <email>lu_zero@gentoo.org</email>
+</maintainer>
+</pkgmetadata>