summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-03 02:55:23 -0500
committerMike Frysinger <vapier@gentoo.org>2016-03-03 02:56:11 -0500
commit935df04d5b2f24f428d38dc7456613b5eaeb03bf (patch)
tree21d2ec105445d2dc9cc1fb20936bef6a5c170d8e /sys-apps/daisydog
parentMerge github#959: www-servers/nginx: Version bump to v1.9.12. (diff)
downloadgentoo-935df04d5b2f24f428d38dc7456613b5eaeb03bf.tar.gz
gentoo-935df04d5b2f24f428d38dc7456613b5eaeb03bf.tar.bz2
gentoo-935df04d5b2f24f428d38dc7456613b5eaeb03bf.zip
sys-apps/daisydog: new package for Chromium OS watchdog daemon
Diffstat (limited to 'sys-apps/daisydog')
-rw-r--r--sys-apps/daisydog/Manifest1
-rw-r--r--sys-apps/daisydog/daisydog-2014.05.30.ebuild35
-rw-r--r--sys-apps/daisydog/files/daisydog.conf.d4
-rwxr-xr-xsys-apps/daisydog/files/daisydog.init.d12
-rw-r--r--sys-apps/daisydog/metadata.xml7
5 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/daisydog/Manifest b/sys-apps/daisydog/Manifest
new file mode 100644
index 000000000000..9e1747859706
--- /dev/null
+++ b/sys-apps/daisydog/Manifest
@@ -0,0 +1 @@
+DIST daisydog-3182aa85c087446e4358370549adc45db21ec124.tar.gz 10395 SHA256 b6185df3583e48e6b2cf16f6425aabe2dfdd94deaf8ac07f8dbd2c9a6f59809d SHA512 0a7312a3d9459487da8d20a80568187f51d4ae786939afbf38b8b89747831b2f7e0e32a3414b5d60863e33bcdebad9e457ff9a8f75143a7b60bf68fc9de17cd5 WHIRLPOOL a30263902a320e49f2d7c65669131476408f0b1d4eec3d5c2e5fbd3407417109184a4b25a5ac1b984b14cc7427fa3fc7b16559daa1da9d85b736a3b30a9721ff
diff --git a/sys-apps/daisydog/daisydog-2014.05.30.ebuild b/sys-apps/daisydog/daisydog-2014.05.30.ebuild
new file mode 100644
index 000000000000..fddff15bd0f4
--- /dev/null
+++ b/sys-apps/daisydog/daisydog-2014.05.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs flag-o-matic
+
+GIT_SHA1="3182aa85c087446e4358370549adc45db21ec124"
+MY_P="${PN}-${GIT_SHA1}"
+
+DESCRIPTION="A very simple /dev/watchdog daemon"
+HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/daisydog/+/master"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz
+ https://chromium.googlesource.com/chromiumos/third_party/daisydog/+archive/${GIT_SHA1}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+S=${WORKDIR}
+
+src_configure() {
+ tc-export CC
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dobin daisydog
+ dodoc README.chromiumos
+
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+}
diff --git a/sys-apps/daisydog/files/daisydog.conf.d b/sys-apps/daisydog/files/daisydog.conf.d
new file mode 100644
index 000000000000..05adc4531a22
--- /dev/null
+++ b/sys-apps/daisydog/files/daisydog.conf.d
@@ -0,0 +1,4 @@
+# /etc/conf.d/daisydog: config file for /etc/init.d/daisydog
+
+# for more info, see `daisydog -h`.
+WATCHDOG_OPTS=""
diff --git a/sys-apps/daisydog/files/daisydog.init.d b/sys-apps/daisydog/files/daisydog.init.d
new file mode 100755
index 000000000000..6fecb16943a4
--- /dev/null
+++ b/sys-apps/daisydog/files/daisydog.init.d
@@ -0,0 +1,12 @@
+#!/sbin/runscript
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/daisydog"
+command_args="${WATCHDOG_OPTS}"
+description="watchdog daemon to pet /dev/watchdog devices"
+start_stop_daemon_args="--make-pidfile --background --pidfile /run/daisydog.pid"
+
+depend() {
+ provide watchdog
+}
diff --git a/sys-apps/daisydog/metadata.xml b/sys-apps/daisydog/metadata.xml
new file mode 100644
index 000000000000..aebca33be179
--- /dev/null
+++ b/sys-apps/daisydog/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+</maintainer>
+</pkgmetadata>