summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /sys-apps/asahi-bless
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sys-apps/asahi-bless')
-rw-r--r--sys-apps/asahi-bless/asahi-bless-0.3.0-r1.ebuild (renamed from sys-apps/asahi-bless/asahi-bless-0.3.0.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/asahi-bless/asahi-bless-0.3.0.ebuild b/sys-apps/asahi-bless/asahi-bless-0.3.0-r1.ebuild
index 7cb997d40f69..c9a4d40bfb75 100644
--- a/sys-apps/asahi-bless/asahi-bless-0.3.0.ebuild
+++ b/sys-apps/asahi-bless/asahi-bless-0.3.0-r1.ebuild
@@ -89,6 +89,11 @@ LICENSE+=" MIT Unicode-DFS-2016 ZLIB"
SLOT="0"
KEYWORDS="~arm64"
+pkg_setup() {
+ linux-info_pkg_setup
+ rust_pkg_setup
+}
+
pkg_pretend() {
if use kernel_linux; then
linux_config_exists || die "No suitable kernel configuration could be found"