summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-25 19:34:27 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-26 10:40:16 +0800
commita052fadde44f92dac091c6546c84ad0bdf4e119e (patch)
tree63c43fc45d27ec07e4ade6cc0a2d423e4862147e /sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild
parentdev-python/google-auth-oauthlib: bump 0.4.1 (diff)
downloadgentoo-a052fadde44f92dac091c6546c84ad0bdf4e119e.tar.gz
gentoo-a052fadde44f92dac091c6546c84ad0bdf4e119e.tar.bz2
gentoo-a052fadde44f92dac091c6546c84ad0bdf4e119e.zip
sci-visualization/tensorboard: update deps
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild')
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild b/sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..0445cb0427b7
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.1.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit python-r1 python-utils-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}