summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/gle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/gle')
-rw-r--r--sci-visualization/gle/Manifest4
-rw-r--r--sci-visualization/gle/files/64gle-gentoo.el6
-rw-r--r--sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch62
-rw-r--r--sci-visualization/gle/files/gle-4.2.4b-parallel.patch21
-rw-r--r--sci-visualization/gle/gle-4.2.4b.ebuild109
-rw-r--r--sci-visualization/gle/gle-4.2.4c.ebuild102
-rw-r--r--sci-visualization/gle/metadata.xml18
7 files changed, 322 insertions, 0 deletions
diff --git a/sci-visualization/gle/Manifest b/sci-visualization/gle/Manifest
new file mode 100644
index 000000000000..0db3aaca70a4
--- /dev/null
+++ b/sci-visualization/gle/Manifest
@@ -0,0 +1,4 @@
+DIST GLEusersguide.pdf 2244780 SHA256 02c13fe038f8b4b7726ac3e6a74410e299f50cdccb2b040d7ed1fbc99b9cfbef
+DIST gle-graphics-4.2.4bf-src.tar.gz 2321414 SHA256 daa6881840b25bcce40fd12c0215ed13b4dfa4a91b3eb665123c890d7238747d SHA512 b7f42cdb09b0d52056997779284c9f02f0bb3049d9aaf2058fe08306568fc963ce845faa4773a16d2a84d937ecbd55f682ea9f6f553fde87d3f1d0d2891207d2 WHIRLPOOL 08d97c82b8b7078113d045f5d363fc6dacf5d78bd64d11d34c42ed19bfe9eb2da283932bc9fe1f8ee6091d4221712b725d06f2797c7d0b1e670c650fc91afa33
+DIST gle-graphics-4.2.4cf-src.tar.gz 2321647 SHA256 21715f2943ca528ec94a8e129175693afc3b59bb03f92540a2150ffe72ab47ef SHA512 961205fcb763ef0fd0b59cfffd144440ea7dea8a54a19e79caa97712245a51ceaaeda5b92ce2571852cec14357af696861bf9cd588aa08622cc8f1f5ebf3959a WHIRLPOOL 11465d836e8763fdc286f38ea9761d806174469b0c52e2f3ce3dacbbb1b5d587f1bf0aade3668b38c2b99668066e372782561ed4b1a2dbaf689095c149a8fcbe
+DIST gle-manual-4.2.2.pdf 2238766 SHA256 fbc4ba2613882d2d4ae3f8484c77aa27a257fc1b0ec02a46085c3651a2ace58e
diff --git a/sci-visualization/gle/files/64gle-gentoo.el b/sci-visualization/gle/files/64gle-gentoo.el
new file mode 100644
index 000000000000..841503ba6eec
--- /dev/null
+++ b/sci-visualization/gle/files/64gle-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; gle site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'gle-mode "gle-mode")
+(add-to-list 'auto-mode-alist '("\\.gle\\'" . gle-mode))
diff --git a/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
new file mode 100644
index 000000000000..1a0c3a4f42c5
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
@@ -0,0 +1,62 @@
+ src/gle/gle-interface/gle-base.h | 4 ++--
+ src/gle/tokens/RefCount.h | 2 +-
+ src/gle/tokens/StringKeyHash.h | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/gle/gle-interface/gle-base.h b/src/gle/gle-interface/gle-base.h
+index 26ce8f3..686c2df 100644
+--- a/src/gle/gle-interface/gle-base.h
++++ b/src/gle/gle-interface/gle-base.h
+@@ -130,7 +130,7 @@ inline GLERefCountObject* GLE_SET_RC(GLERefCountObject* rc, GLERefCountObject* v
+
+ template <class T> class GLERCVector : public vector< GLERC<T> > {
+ public:
+- inline void add(T* elem) { push_back(GLERC<T>(elem)); }
++ inline void add(T* elem) { this->push_back(GLERC<T>(elem)); }
+ inline T* get(int i) { return (*this)[i].get(); }
+ };
+
+@@ -147,7 +147,7 @@ public:
+ }
+ void deleteAll() {
+ for (typename vector<T*>::size_type i = 0; i < vector<T*>::size(); i++) {
+- T* elem = at(i);
++ T* elem = this->at(i);
+ if (elem != NULL) delete elem;
+ }
+ }
+diff --git a/src/gle/tokens/RefCount.h b/src/gle/tokens/RefCount.h
+index eef1824..d43540b 100644
+--- a/src/gle/tokens/RefCount.h
++++ b/src/gle/tokens/RefCount.h
+@@ -125,7 +125,7 @@ public:
+ template <class T> class MutableRefCountPtr : public RefCountPtr<T> {
+ public:
+ inline RefCountPtr<T>& operator =(RefCountPtr<T> src) {
+- setPtr(src.get()); return *this;
++ this->setPtr(src.get()); return *this;
+ };
+ };
+
+diff --git a/src/gle/tokens/StringKeyHash.h b/src/gle/tokens/StringKeyHash.h
+index 7db46c3..0966676 100644
+--- a/src/gle/tokens/StringKeyHash.h
++++ b/src/gle/tokens/StringKeyHash.h
+@@ -254,7 +254,7 @@ public:
+ return i->second;
+ } else {
+ ElemType nelem(key);
+- insert(StringKeyPair<ElemType>(key, nelem));
++ this->insert(StringKeyPair<ElemType>(key, nelem));
+ return nelem;
+ }
+ }
+@@ -309,7 +309,7 @@ public:
+ }
+
+ void add_item(int key, ElemType elem) {
+- insert(IntKeyPair<ElemType>(key, elem));
++ this->insert(IntKeyPair<ElemType>(key, elem));
+ }
+ };
+
diff --git a/sci-visualization/gle/files/gle-4.2.4b-parallel.patch b/sci-visualization/gle/files/gle-4.2.4b-parallel.patch
new file mode 100644
index 000000000000..1eff8c067102
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4b-parallel.patch
@@ -0,0 +1,21 @@
+--- src/gui/MakefileAC.in.orig 2010-01-06 20:10:04.000000000 +0000
++++ src/gui/MakefileAC.in 2010-01-06 20:21:15.000000000 +0000
+@@ -84,14 +84,14 @@
+ qmake:
+ $(QMAKE_PROG) $(QMAKE_OPTS)
+
+-domake:
+- $(MAKE_PROG)
++domake: Makefile
++ $(MAKE)
+
+-repmake:
++repmake: Makefile
+ perl ../../platform/autopackage/qt-replace.pl Makefile
+
+ doclean:
+- -$(MAKE_PROG) clean
++ -$(MAKE) clean
+ -@$(RM) qgle install_qgle_name_mac Makefile
+ -@$(RMDIR) moc
+ -@$(RMDIR) objects
diff --git a/sci-visualization/gle/gle-4.2.4b.ebuild b/sci-visualization/gle/gle-4.2.4b.ebuild
new file mode 100644
index 000000000000..fa8f401df849
--- /dev/null
+++ b/sci-visualization/gle/gle-4.2.4b.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils elisp-common qt4-r2 flag-o-matic autotools
+
+DESCRIPTION="Graphics Layout Engine"
+HOMEPAGE="http://glx.sourceforge.net/"
+MY_P=${PN}-graphics-${PV}
+MAN_V=4.2.2
+SRC_URI="mirror://sourceforge/glx/${MY_P}f-src.tar.gz
+ doc? ( mirror://sourceforge/glx/${PN}-manual-${MAN_V}.pdf
+ mirror://sourceforge/glx/GLEusersguide.pdf )"
+SLOT="0"
+LICENSE="BSD-2 emacs? ( GPL-2 ) qt4? ( GPL-2 )"
+IUSE="X qt4 jpeg png tiff doc emacs vim-syntax"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ qt4? ( dev-qt/qtopengl:4 )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ virtual/latex-base
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ eaclocal
+ eautoconf
+}
+
+src_configure() {
+ # CPPFLAGS are understood as C++ flags
+ append-cppflags ${CXXFLAGS}
+ econf \
+ --without-rpath \
+ --with-manip \
+ $(use_with qt4 qt /usr) \
+ $(use_with X x) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff)
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ cd contrib/editors/highlighting
+ mv ${PN}-emacs.el ${PN}-mode.el
+ elisp-compile ${PN}-mode.el || die
+ fi
+}
+
+src_install() {
+ # -jN failed to install some data files
+ emake -j1 DESTDIR="${D}" install
+ rmdir "${D}"/usr/share/doc/gle-graphics || die "rmdir gle-graphics failed"
+ dodoc README.txt
+
+ if use qt4; then
+ newicon src/gui/images/gle_icon.png gle.png
+ make_desktop_entry qgle GLE gle
+ newdoc src/gui/readme.txt gui_readme.txt
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-manual-${MAN_V}.pdf \
+ "${DISTDIR}"/GLEusersguide.pdf
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/editors/highlighting/gle-mode.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/64gle-gentoo.el || die
+ fi
+
+ if use vim-syntax ; then
+ dodir /usr/share/vim/vimfiles/ftplugins \
+ /usr/share/vim/vimfiles/indent \
+ /usr/share/vim/vimfiles/syntax
+ cd contrib/editors/highlighting/vim
+ chmod 644 ftplugin/* indent/* syntax/*
+ insinto /usr/share/vim/vimfiles/ftplugins
+ doins ftplugin/*
+ insinto /usr/share/vim/vimfiles/indent
+ doins indent/*
+ insinto /usr/share/vim/vimfiles/syntax
+ doins syntax/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-visualization/gle/gle-4.2.4c.ebuild b/sci-visualization/gle/gle-4.2.4c.ebuild
new file mode 100644
index 000000000000..05d4cff36889
--- /dev/null
+++ b/sci-visualization/gle/gle-4.2.4c.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils elisp-common qt4-r2 flag-o-matic autotools
+
+DESCRIPTION="Graphics Layout Engine"
+HOMEPAGE="http://glx.sourceforge.net/"
+MY_P=${PN}-graphics-${PV}
+MAN_V=4.2.2
+SRC_URI="mirror://sourceforge/glx/${MY_P}f-src.tar.gz
+ doc? ( mirror://sourceforge/glx/${PN}-manual-${MAN_V}.pdf
+ mirror://sourceforge/glx/GLEusersguide.pdf )"
+SLOT="0"
+LICENSE="BSD-2 emacs? ( GPL-2 ) qt4? ( GPL-2 )"
+IUSE="X qt4 jpeg png tiff doc emacs vim-syntax"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ qt4? ( dev-qt/qtopengl:4 )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ virtual/latex-base
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.2.4b-parallel.patch
+ eaclocal
+ eautoconf
+}
+
+src_configure() {
+ # CPPFLAGS are understood as C++ flags
+ append-cppflags ${CXXFLAGS}
+ econf \
+ --without-rpath \
+ --with-manip \
+ $(use_with qt4 qt "${EPREFIX}"/usr) \
+ $(use_with X x) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff)
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ cd contrib/editors/highlighting
+ mv ${PN}-emacs.el ${PN}-mode.el
+ elisp-compile ${PN}-mode.el || die
+ fi
+}
+
+src_install() {
+ # -jN failed to install some data files
+ emake -j1 DESTDIR="${D}" install
+ rmdir "${ED}"/usr/share/doc/gle-graphics || die "rmdir gle-graphics failed"
+ dodoc README.txt
+
+ if use qt4; then
+ newicon src/gui/images/gle_icon.png gle.png
+ make_desktop_entry qgle GLE gle
+ newdoc src/gui/readme.txt gui_readme.txt
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-manual-${MAN_V}.pdf \
+ "${DISTDIR}"/GLEusersguide.pdf
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/editors/highlighting/gle-mode.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/64gle-gentoo.el || die
+ fi
+
+ if use vim-syntax ; then
+ dodir /usr/share/vim/vimfiles/{ftplugins,indent,syntax}
+ cd contrib/editors/highlighting/vim || die
+ chmod 644 ftplugin/* indent/* syntax/*
+ insinto /usr/share/vim/vimfiles
+ doins -r ftplugin indent syntax
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-visualization/gle/metadata.xml b/sci-visualization/gle/metadata.xml
new file mode 100644
index 000000000000..c4293022a181
--- /dev/null
+++ b/sci-visualization/gle/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>
+ GLE (Graphics Layout Engine) is a high-quality graphics package for
+ scientists, combining a user-friendly scripting language with a full
+ range of facilities for producing publication-quality graphs,
+ diagrams, posters and slides.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">glx</remote-id>
+ </upstream>
+</pkgmetadata>