summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-09-23 17:13:50 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-23 17:32:23 +0200
commit669d2051abf0b109273b2f791c7d7bcd4589f2f0 (patch)
tree3f7473dbc4ef5eae4ca2d0f225af8f0d16fde118 /sci-physics
parentsci-geosciences/josm-bin: drop old (diff)
downloadgentoo-669d2051abf0b109273b2f791c7d7bcd4589f2f0.tar.gz
gentoo-669d2051abf0b109273b2f791c7d7bcd4589f2f0.tar.bz2
gentoo-669d2051abf0b109273b2f791c7d7bcd4589f2f0.zip
sci-physics/rivet: add 4.0.1
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/38744 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/rivet/Manifest1
-rw-r--r--sci-physics/rivet/metadata.xml1
-rw-r--r--sci-physics/rivet/rivet-4.0.1.ebuild114
-rw-r--r--sci-physics/rivet/rivet-9999.ebuild37
4 files changed, 134 insertions, 19 deletions
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
index 0afa0fcb5895..ae49f22dbe86 100644
--- a/sci-physics/rivet/Manifest
+++ b/sci-physics/rivet/Manifest
@@ -1,2 +1,3 @@
DIST rivet-3.1.10.tar.gz 36327949 BLAKE2B 76d8ed8b3ee0eda2f7f03b4e423c46f49d39006a4ab0b66622ab2b2a7817f91f1f7bc648ecfb2e9d2d73da1619069c25fe9078c9b04a54cce8e1a71c33dc6b1a SHA512 9a0a3516686b82c7cf667bab230229553e9e49e5656d763046a86baa1f2d3fdb3167e53540533ebe5da532e71f15140ab8dd16de4075fd76e634e0c6919155e4
DIST rivet-3.1.9.tar.gz 37599489 BLAKE2B a470254b8d4303f5738ca9c4ff0061a000d06e37ee805d909dfc709f14e5ebc8958739912f9b9bbf80bb38e79f4b8df057d7ac59c6924fddd56918102243aeed SHA512 21c1ca6eda7ac7d0394875cd8b972d3e65df1bf0e773d2094bab1997c6fab67381d6202aef8024eaa363c03b2345bae95d54dca1ce38c2499ddc24a7e7f93bdc
+DIST rivet-4.0.1.tar.gz 29061104 BLAKE2B 33bb4d003c817e44c2b5ecbf36f0c1d16954b52eb4883531f030af30608e5c499378fc3b3157a4608de63cc07617acbfa56cc124cdf61bbaf2a42841b28d478c SHA512 11704dd4f5c2d6981683f3e0f2d201c2554693dbc5a16c50a064cf9ff890b5dc7039ed2fb09720de21693fcd4ffaf10aba52a6240c65bbcb987a6f48512a0543
diff --git a/sci-physics/rivet/metadata.xml b/sci-physics/rivet/metadata.xml
index a004d00e7bbe..23bb49548be9 100644
--- a/sci-physics/rivet/metadata.xml
+++ b/sci-physics/rivet/metadata.xml
@@ -18,6 +18,7 @@
<flag name="zlib">Build with zlib</flag>
<flag name="hepmc3">Build with HepMC3</flag>
<flag name="hepmc2">Build with HepMC2</flag>
+ <flag name="highfive">Build with hdf5 and highfive</flag>
</use>
<upstream>
<remote-id type="gitlab">hepcedar/rivet</remote-id>
diff --git a/sci-physics/rivet/rivet-4.0.1.ebuild b/sci-physics/rivet/rivet-4.0.1.ebuild
new file mode 100644
index 000000000000..6c8d466288de
--- /dev/null
+++ b/sci-physics/rivet/rivet-4.0.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit python-single-r1 flag-o-matic autotools optfeature bash-completion-r1
+
+MY_PN="Rivet"
+MY_PF=${MY_PN}-${PV}
+
+DESCRIPTION="Rivet toolkit (Robust Independent Validation of Experiment and Theory)"
+HOMEPAGE="
+ https://rivet.hepforge.org/
+ https://gitlab.com/hepcedar/rivet
+"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/hepcedar/rivet"
+else
+ SRC_URI="https://www.hepforge.org/archive/rivet/${MY_PF}.tar.gz -> ${P}.tar.gz"
+ S=${WORKDIR}/${MY_PF}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="4"
+IUSE="+zlib +python +highfive"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=sci-physics/fastjet-3.4.0[plugins]
+ >=sci-physics/fastjet-contrib-1.048
+ >=sci-physics/hepmc-3.1.1:3=[-cm(-),gev(+)]
+ highfive? (
+ sci-libs/HighFive
+ sci-libs/hdf5[cxx]
+ )
+
+ sci-libs/gsl
+ zlib? ( sys-libs/zlib )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ ')
+ >=sci-physics/yoda-2[${PYTHON_SINGLE_USEDEP}]
+ )
+ !python? (
+ >=sci-physics/yoda-2
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-shells/bash
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.29.24[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.6-binreloc.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Eigen complains about alignment (see https://gitlab.com/libeigen/eigen/-/issues/2523).
+ # does this affect more cpus?
+ replace-cpu-flags znver1 x86-64
+ # not posix compatible, only bash
+ CONFIG_SHELL=${ESYSROOT}/bin/bash econf \
+ $(use_with zlib zlib "${ESYSROOT}/usr") \
+ --with-hepmc3="${ESYSROOT}/usr" \
+ $(usex highfive "--with-highfive=${ESYSROOT}/usr" "") \
+ --with-yoda="${ESYSROOT}/usr" \
+ --with-fastjet="${ESYSROOT}/usr" \
+ $(use_enable python pyext) \
+ $(usex python CYTHON="${ESYSROOT}/usr/bin/cython")
+}
+
+src_install() {
+ default
+ use python && python_optimize
+ find "${ED}" -name '*.la' -delete || die
+ if use python ; then
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
+ bashcomp_alias ${PN} \
+ ${PN}-config \
+ ${PN}-build \
+ ${PN}-cmphistos \
+ make-plots \
+ ${PN}-mkhtml-tex \
+ ${PN}-mkhtml
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+ fi
+}
+
+pkg_postinstall() {
+ optfeature "latex plotting support" virtual/latex-base media-gfx/imagemagick app-text/ghostscript-gpl
+ optfeature "python plotting support" dev-python/matplotlib
+}
diff --git a/sci-physics/rivet/rivet-9999.ebuild b/sci-physics/rivet/rivet-9999.ebuild
index ab878070845d..6c8d466288de 100644
--- a/sci-physics/rivet/rivet-9999.ebuild
+++ b/sci-physics/rivet/rivet-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{11..12} )
inherit python-single-r1 flag-o-matic autotools optfeature bash-completion-r1
@@ -18,7 +18,6 @@ HOMEPAGE="
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/hepcedar/rivet"
- EGIT_BRANCH="release-3-1-x"
else
SRC_URI="https://www.hepforge.org/archive/rivet/${MY_PF}.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}/${MY_PF}
@@ -26,18 +25,20 @@ else
fi
LICENSE="GPL-3+"
-SLOT="3"
-IUSE="+hepmc3 hepmc2 +zlib +python"
+SLOT="4"
+IUSE="+zlib +python +highfive"
REQUIRED_USE="
- ^^ ( hepmc3 hepmc2 )
python? ( ${PYTHON_REQUIRED_USE} )
"
RDEPEND="
>=sci-physics/fastjet-3.4.0[plugins]
>=sci-physics/fastjet-contrib-1.048
- hepmc2? ( sci-physics/hepmc:2=[-cm(-),gev(+)] )
- hepmc3? ( sci-physics/hepmc:3=[-cm(-),gev(+)] )
+ >=sci-physics/hepmc-3.1.1:3=[-cm(-),gev(+)]
+ highfive? (
+ sci-libs/HighFive
+ sci-libs/hdf5[cxx]
+ )
sci-libs/gsl
zlib? ( sys-libs/zlib )
@@ -46,12 +47,10 @@ RDEPEND="
$(python_gen_cond_dep '
dev-python/matplotlib[${PYTHON_USEDEP}]
')
- >=sci-physics/yoda-1.9.8[${PYTHON_SINGLE_USEDEP}]
- <sci-physics/yoda-2[${PYTHON_SINGLE_USEDEP}]
+ >=sci-physics/yoda-2[${PYTHON_SINGLE_USEDEP}]
)
!python? (
- >=sci-physics/yoda-1.9.8
- <sci-physics/yoda-2
+ >=sci-physics/yoda-2
)
"
DEPEND="${RDEPEND}"
@@ -66,7 +65,6 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.1.6-binreloc.patch
- "${FILESDIR}"/${PN}-3.1.9-pythontests.patch
)
pkg_setup() {
@@ -85,8 +83,8 @@ src_configure() {
# not posix compatible, only bash
CONFIG_SHELL=${ESYSROOT}/bin/bash econf \
$(use_with zlib zlib "${ESYSROOT}/usr") \
- $(usex hepmc2 "--with-hepmc=${ESYSROOT}/usr" "") \
- $(usex hepmc3 "--with-hepmc3=${ESYSROOT}/usr" "") \
+ --with-hepmc3="${ESYSROOT}/usr" \
+ $(usex highfive "--with-highfive=${ESYSROOT}/usr" "") \
--with-yoda="${ESYSROOT}/usr" \
--with-fastjet="${ESYSROOT}/usr" \
$(use_enable python pyext) \
@@ -99,17 +97,18 @@ src_install() {
find "${ED}" -name '*.la' -delete || die
if use python ; then
newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
- bashcomp_alias ${PN} ${PN}-config \
+ bashcomp_alias ${PN} \
+ ${PN}-config \
${PN}-build \
- ${PN}-buildplugin \
${PN}-cmphistos \
make-plots \
- ${PN}-mkhtml \
- ${PN}-mkhtml-mpl
+ ${PN}-mkhtml-tex \
+ ${PN}-mkhtml
rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
fi
}
pkg_postinstall() {
- optfeature "plotting support" virtual/latex-base media-gfx/imagemagick app-text/ghostscript-gpl
+ optfeature "latex plotting support" virtual/latex-base media-gfx/imagemagick app-text/ghostscript-gpl
+ optfeature "python plotting support" dev-python/matplotlib
}