summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-09-20 19:09:22 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-09-20 19:09:59 +0300
commit240c051971ed9f661743a0d5e5a98ea63189e0e2 (patch)
tree58984924b0afe1b9b979db4dafe27ab189cff4d2 /sci-mathematics
parentdev-lang/yap: QA fixups (diff)
downloadgentoo-240c051971ed9f661743a0d5e5a98ea63189e0e2.tar.gz
gentoo-240c051971ed9f661743a0d5e5a98ea63189e0e2.tar.bz2
gentoo-240c051971ed9f661743a0d5e5a98ea63189e0e2.zip
sci-mathematics/mathematica: Fix avahi-related sandbox error
Patch by vowstar <vowstar@gmail.com> Closese: https://bugs.gentoo.org/739130 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild b/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
index b15d9ff67885..20aaab87c6fa 100644
--- a/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
+++ b/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
@@ -36,7 +36,20 @@ QA_PREBUILT="opt/*"
S=${WORKDIR}
src_unpack() {
- /bin/sh "${DISTDIR}/${A}" --nox11 --confirm -- -auto "-targetdir=${S}/${M_TARGET}" "-execdir=${S}/opt/bin" || die
+ /bin/sh "${DISTDIR}/${A}" --nox11 --keep --target "${S}/unpack" -- "-help" || die
+}
+
+src_prepare() {
+ default
+
+ pushd "${S}/unpack" > /dev/null || die
+
+ # fix ACCESS DENIED issue when installer check the avahi-daemon
+ sed -e "s:avahi-daemon -c:true:g" -i "Unix/Installer/MathInstaller" || die
+
+ /bin/sh "Unix/Installer/MathInstaller" -auto "-targetdir=${S}/${M_TARGET}" "-execdir=${S}/opt/bin" || die
+
+ popd > /dev/null || die
}
src_install() {