summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-06 14:26:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-06 14:30:31 +0200
commitc60a1f1c9144a65c5bd04296bac73be150873a03 (patch)
tree9b40c0b97ff4ee854d2b5081e369c6eba1cfb8cd /sci-libs
parentdev-python/uvloop: Require <dev-python/cython-3 (diff)
downloadgentoo-c60a1f1c9144a65c5bd04296bac73be150873a03.tar.gz
gentoo-c60a1f1c9144a65c5bd04296bac73be150873a03.tar.bz2
gentoo-c60a1f1c9144a65c5bd04296bac73be150873a03.zip
sci-libs/scikit-learn: Require <dev-python/cython-3
Bug: https://bugs.gentoo.org/911369 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild b/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
index e498e32de5a9..205d7e0ab2b7 100644
--- a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
+++ b/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -28,12 +28,15 @@ DEPEND="
RDEPEND="
${DEPEND}
dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
dev-python/joblib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/threadpoolctl[${PYTHON_USEDEP}]
"
+# <cython-3: https://bugs.gentoo.org/911369
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
# For some reason this wants to use urllib to fetch things from the internet