summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-04-16 12:52:13 -0400
committerSam James <sam@gentoo.org>2024-04-16 23:27:44 +0100
commit265cd7235511152398f499cdbe8081cf2762cdd5 (patch)
tree5e04456aa2612aa12e85923ecc6fe31163184efe /sci-libs
parentgui-wm/hyprland: drop old versions, 0.38.0, 0.39.0 (diff)
downloadgentoo-265cd7235511152398f499cdbe8081cf2762cdd5.tar.gz
gentoo-265cd7235511152398f499cdbe8081cf2762cdd5.tar.bz2
gentoo-265cd7235511152398f499cdbe8081cf2762cdd5.zip
sci-libs/libqalculate: add 5.0.0b
- Fixes ABI breakage - Bumps SONAME subslot - Adds MY_PV and S variables to fix directory path Closes: https://bugs.gentoo.org/930068 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/36268 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-5.0.0b.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index cc554565d92f..029cd91e973a 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -4,3 +4,4 @@ DIST libqalculate-4.7.0.tar.gz 2618347 BLAKE2B 1ec01e124d9c96a2651f3e2a82a4eb8ae
DIST libqalculate-4.8.0.tar.gz 2625669 BLAKE2B 957adcc6b5dabee4d9d6a593a4d5c894e6db05856875a241b1090bada49a0c802c94076a347df6b9b60d088edcba6f5e50ffa0d4a4517ead6da9cebc2f02c592 SHA512 db41bf883520d72f5d7c80b78492aba5367e74a6c5c452a420d6ecc79ae8f1dfa208c13bfff96ea699d31189cc49c264cf1b543946e4ec39b9df97a386c215ea
DIST libqalculate-4.8.1.tar.gz 2625564 BLAKE2B 017188bd43da03c398ed17e883f460637d1af35df9643ac62c938f5aa189431fee49143d517c2d4489c4cca030f1220129f9dfce448969a9601c74273bfdb1a9 SHA512 e4e3f884ac42b706ee79f8fa37fbff69a30dc3f24edbe66b259507723dc3f028243acea4cb29dd68d933e7e357a55207aaf619fe9f66caa118a212de06c2a8d4
DIST libqalculate-5.0.0.tar.gz 2674322 BLAKE2B 1ae2203c4443b57198a0e7862361f732ae8428cb6b55942f9ff9984f0956c5a2cda3fd9f5a49fa98c10526879e9ce2751a9e5c33d1e6092503640da13844df0d SHA512 d3467e79e1454a76ee0c4d8795241c105d42580f95321e24b0657d99535ed8827809cc7ec0474c9e75cd668158aa84a500e5bd3a92dd0f4a3d1e4fc91811c399
+DIST libqalculate-5.0.0b.tar.gz 2674304 BLAKE2B 8f41f141aedac2f1ccdd8b48182f972b29ae2835b1a4844ba076112754061f06970817ec3e1248c50c3c9792d41927e277b05bd8933b9a63446e0d56d5449a8b SHA512 88bddd961fca48b0c971ba035cd295d642aac009164654b0c6b18e1c72892c69614f3dd90d5b851c05dfab41fda9a6dd18fbaecac9d28bfed387a7063280ebc7
diff --git a/sci-libs/libqalculate/libqalculate-5.0.0b.ebuild b/sci-libs/libqalculate/libqalculate-5.0.0b.ebuild
new file mode 100644
index 000000000000..e2b981608fed
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-5.0.0b.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with sci-calculators/qalculate-gtk and sci-calculators/qalculate-qt
+
+inherit toolchain-funcs
+
+MY_PV="${PV//b/}"
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}"/"${PN}-${MY_PV}"
+
+LICENSE="GPL-2+"
+# SONAME changes pretty often on bumps. Check!
+SLOT="0/23"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot +hardened readline test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/gmp:=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ # Needed for po-defs/Makefile
+ export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
+ export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"
+
+ # bug #792027
+ tc-export CC
+
+ econf \
+ $(use_enable test tests) \
+ $(use_enable test unittests) \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_enable !hardened insecure) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}