summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-03-18 16:54:36 +0000
committerSam James <sam@gentoo.org>2024-06-26 10:19:16 +0100
commit1741a387380154228da762046fd065698942dc58 (patch)
tree71f626c34e5c21a6966d6fe9babd59882c4e135d /sci-libs
parentsci-libs/rocRAND: add 6.1.1 (diff)
downloadgentoo-1741a387380154228da762046fd065698942dc58.tar.gz
gentoo-1741a387380154228da762046fd065698942dc58.tar.bz2
gentoo-1741a387380154228da762046fd065698942dc58.zip
sci-libs/rocThrust: add 6.1.1
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocThrust/Manifest1
-rw-r--r--sci-libs/rocThrust/metadata.xml14
-rw-r--r--sci-libs/rocThrust/rocThrust-6.1.1.ebuild56
3 files changed, 66 insertions, 5 deletions
diff --git a/sci-libs/rocThrust/Manifest b/sci-libs/rocThrust/Manifest
index 5c109bf5006a..3916366accb8 100644
--- a/sci-libs/rocThrust/Manifest
+++ b/sci-libs/rocThrust/Manifest
@@ -1,2 +1,3 @@
DIST rocThrust-5.1.3.tar.gz 1186518 BLAKE2B 2defe71247915940917438d4f0d0a811dca7de39e5168248968fa9c165b81d94b0e20f3df9b84db1fbdcd2eb87942dec5d3adbbe1a699eb51eeb4e1b2f0a88d0 SHA512 189c70343a410cf3f3c1589ef24c68a38b5270d8780d15261a124b8250f279a3c3c7afef38e6310d57cb1741b3ee75f0b4ac0bb9dfcf4a4fb0e7e6c0516faf74
DIST rocThrust-5.7.1.tar.gz 1122808 BLAKE2B 41a5d57d03c7f95baf861b772c9513c7fbc26eee8a2f388897eb9b9f9fad3cdad81e2a79932c5b9a6d88b4e1596bf64e59e01337943a036ddb792f7b352ecd31 SHA512 52a9640808f0ed78ae2d6f25e741af59ae4e977535a0431f16c0fa1ee9a395e6f389cf29e61c02ac274cf16fcd193e5df6fb2edc340059ab282ed7cd877fc8b4
+DIST rocThrust-6.1.1.tar.gz 1147635 BLAKE2B e71288a4666ba1f23cf85d2d269f61f9085efaeb2921b7f3142c5ce0808380b27a8c07945a44b6a651747046020b412838a667232b1ba65308fd7fd336b840b4 SHA512 30eeb6df73ee0dc2361879337faae09cf19cd151510c6e22d774c22b4be19272f9980cc6ba2b2e42f43738a1e475f49fcb4384d66b24639746a05685a90e37d4
diff --git a/sci-libs/rocThrust/metadata.xml b/sci-libs/rocThrust/metadata.xml
index 61a33c63bbf4..03efe0482dfe 100644
--- a/sci-libs/rocThrust/metadata.xml
+++ b/sci-libs/rocThrust/metadata.xml
@@ -8,10 +8,14 @@
<email>gentoo@holzke.net</email>
<name>Wilfried Holzke</name>
</maintainer>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
<upstream>
- <remote-id type="github">ROCm-Developer-Tools/rocThrust</remote-id>
+ <remote-id type="github">ROCm/rocThrust</remote-id>
</upstream>
- <use>
- <flag name="benchmark">Build and install benchmark binary.</flag>
- </use>
-</pkgmetadata>
+ <use>
+ <flag name="benchmark">Build and install benchmark binary.</flag>
+ </use>
+</pkgmetadata> \ No newline at end of file
diff --git a/sci-libs/rocThrust/rocThrust-6.1.1.ebuild b/sci-libs/rocThrust/rocThrust-6.1.1.ebuild
new file mode 100644
index 000000000000..7a04d78cbe0f
--- /dev/null
+++ b/sci-libs/rocThrust/rocThrust-6.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="HIP back-end for the parallel algorithm library Thrust"
+HOMEPAGE="https://github.com/ROCm/rocThrust"
+SRC_URI="https://github.com/ROCm/rocThrust/archive/rocm-${PV}.tar.gz -> rocThrust-${PV}.tar.gz"
+S="${WORKDIR}/rocThrust-rocm-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="benchmark test"
+REQUIRED_USE="
+ benchmark? ( ${ROCM_REQUIRED_USE} )
+ test? ( ${ROCM_REQUIRED_USE} )
+"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocPRIM:${SLOT}[${ROCM_USEDEP}]
+ test? ( dev-cpp/gtest )"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-build/cmake-3.22"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0-operator_new.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DBUILD_BENCHMARKS=$(usex benchmark ON OFF)
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}
+
+src_test() {
+ check_amdgpu
+ # uses HMM to fit tests to default <512M iGPU VRAM
+ ROCTHRUST_USE_HMM="1" cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+
+ use benchmark && dobin "${BUILD_DIR}"/benchmarks/benchmark_thrust_bench
+}