summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/pycifrw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/pycifrw')
-rw-r--r--sci-libs/pycifrw/Manifest2
-rw-r--r--sci-libs/pycifrw/metadata.xml12
-rw-r--r--sci-libs/pycifrw/pycifrw-3.6.2.ebuild23
-rw-r--r--sci-libs/pycifrw/pycifrw-4.1.1.ebuild23
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/pycifrw/Manifest b/sci-libs/pycifrw/Manifest
new file mode 100644
index 000000000000..ed2a2156af8d
--- /dev/null
+++ b/sci-libs/pycifrw/Manifest
@@ -0,0 +1,2 @@
+DIST PyCifRW-3.6.2.tar.gz 356813 SHA256 4d0a67311460e1f9ca65780d6cb34ec07e069d07ac19233dac9a0a6b50d0a0e8 SHA512 21b5738deb54a7293faef2d0cb578047be15feb1e2a0f4e6566777977ec8955c4281e6eddc920c08705f553acec4a574b52ca60b37b8bc0269d6b2cdaec7bf71 WHIRLPOOL 2e03e9e66b93002894831d893e69b792ce2d65362cfbe3191334c0807b528df13da881fada083f1384efafde74799b6cad9ef5d97a55b3136aaa8f36daf6788d
+DIST PyCifRW-4.1.1.tar.gz 446258 SHA256 00192f708a4840695caccabdff65f558d2842d2da6d7ff0e538417aa0aaedbae SHA512 5358080528851b1341c5294ade0741450963bea26b731ec1cb820e012d921dd329137413b3ca1ffb7d7915a4796415f8b3f9654711052ac744d8db7d6104e18d WHIRLPOOL 8835c3f957b7a48fd5026c11150fef483fab16c16a88b1807b61e754f30222482a56ba4d4b299f1d692c15f383e90677992b5ec55d0ee873eee327725de34f77
diff --git a/sci-libs/pycifrw/metadata.xml b/sci-libs/pycifrw/metadata.xml
new file mode 100644
index 000000000000..e79aa012d6e8
--- /dev/null
+++ b/sci-libs/pycifrw/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">PyCifRW</remote-id>
+ <remote-id type="bitbucket">jamesrhester/pycifrw</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/pycifrw/pycifrw-3.6.2.ebuild b/sci-libs/pycifrw/pycifrw-3.6.2.ebuild
new file mode 100644
index 000000000000..a8d0be486412
--- /dev/null
+++ b/sci-libs/pycifrw/pycifrw-3.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="PyCifRW"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides support for reading and writing of CIF using python"
+HOMEPAGE="https://pypi.python.org/pypi/PyCifRW/ https://bitbucket.org/jamesrhester/pycifrw/wiki/Home"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ASRP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
diff --git a/sci-libs/pycifrw/pycifrw-4.1.1.ebuild b/sci-libs/pycifrw/pycifrw-4.1.1.ebuild
new file mode 100644
index 000000000000..01b2ae90e616
--- /dev/null
+++ b/sci-libs/pycifrw/pycifrw-4.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="PyCifRW"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Reading and writing CIF (Crystallographic Information Format) files"
+HOMEPAGE="https://pypi.python.org/pypi/PyCifRW/ https://bitbucket.org/jamesrhester/pycifrw/wiki/Home"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ASRP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"