summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-27 00:29:26 -0400
committerSam James <sam@gentoo.org>2024-03-27 04:49:47 +0000
commit94513b4963654fc66f22f70db5a797f86bb79546 (patch)
tree4461c8247d02174f3fb636f7367a73759e788bee /sci-libs/netcdf-cxx
parentsci-libs/matio: make sure elibtoolize is applied (diff)
downloadgentoo-94513b4963654fc66f22f70db5a797f86bb79546.tar.gz
gentoo-94513b4963654fc66f22f70db5a797f86bb79546.tar.bz2
gentoo-94513b4963654fc66f22f70db5a797f86bb79546.zip
sci-libs/netcdf-cxx: make sure elibtoolize is applied
Since the libtool available for 4.2 is very old, that means running a full eautoreconf. Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/netcdf-cxx')
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild9
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild9
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.3.1.ebuild9
3 files changed, 24 insertions, 3 deletions
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
index 897094334974..04c76791f47d 100644
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="C++ library for netCDF"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
SRC_URI="https://www.unidata.ucar.edu/downloads/netcdf/ftp/${P}.tar.gz"
@@ -15,6 +17,11 @@ IUSE="examples"
RDEPEND=">=sci-libs/netcdf-4.2:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
index a628593681d9..1a1079b72566 100644
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
MYP=${PN}4-${PV}
DESCRIPTION="C++ library for netCDF"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -24,6 +26,11 @@ PATCHES=(
"${FILESDIR}"/${P}-slibtool.patch
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_install() {
default
use examples && dodoc -r examples
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1.ebuild
index 243ba75a2e3a..559d4d5483dc 100644
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1.ebuild
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
MYP=${PN}4-${PV}
DESCRIPTION="C++ library for netCDF"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -24,6 +26,11 @@ PATCHES=(
"${FILESDIR}"/${P}-slibtool.patch
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf --disable-static
}